Info

für alle Microsoft Betriebssysteme

© 2000/2005 by Frank Ullrich

Für weitere Informationen besuchen Sie unsere Homepage unter:

http://www.winfaq.de

  • Nutzungsrecht

  • Copyright

  • Danksagungen


Copyright

Copyrighthinweise

Alle Firmen- und Produktnamen unterliegen den länderspezifischen Copyrightbestimmungen und sind geschützt. Die Verwendung und Verbreitung unterliegt gewissen Bestimmungen.

Der Autor dieser Seiten haftet nicht für etwaige Namesverletzungen durch Programme oder Domainnamen, auf welche verlinkt wird.

Für etwaige Schäden, welche durch Tipps dieser Seite oder durch Software dieser Seite verursacht wird, haftet der Autor ebenfalls nicht.

Ein Teil der Texte wurde mit Genehmigung des Rechteinhabers hier veröffentlicht.

Dieses Textdokument ist aufgrund des Urheberrechtgesetzes zumindest innerhalb des Geltungsbereiches der Bundesrepublik Deutschland geschützt und darf nicht ohne Einwilligung des Rechteinhabers kopiert, verändert, verbreitet oder in einer sonstigen Form beschränkt werden.

Verstöße werden wegen eines Verstoßes gegen das Urheberschutzgesetz verfolgt.

Copyright © 1996/2005 by Frank Ullrich

http://www.winfaq.de


Nutzungsrecht

Die Standardfunktionen des "Registry System Wizard" und die Hilfedatei "WinFAQ" kann von Privatpersonen kostenfrei benutzt werden. Weiterhin dürfen Schulen und allgemeinnützige Einrichtungen die Software kostenlos einsetzen.

Für die erweiterten Funktionen muss eine entsprechende Lizenz erworben werden, darunter fallen folgende Funktionen:

- Erstellen von REG-Dateien (hier nur bei REG-Listen, einzelne Tipps können immer noch exportiert werden).

- Erstellen von ADM-Dateien

- Netzwerkzugriff

- FTP-Update mit aktuellen Tipps und Bugfixes

Die ersten 3 Funktionen können nach einer Wartezeit getestet werden. Privatanwender die diese Funktionen nur gelegentlich benutzen, können so noch darauf zurückgreifen.

Wer das Programm gut findet und diese Funktion öfter benötigt, oder das Team unterstützen möchte, kann eine entsprechende Lizenz erwerben.

Für den gewerblichen Einsatz muss nach einer Testzeit von 30 Tagen eine Lizenz bestellt werden, ansonsten müssen Sie das Programm wieder von Ihrem System entfernen.

Allen Personen mit einer Lizenz wird ein entsprechender Support über E-Mail für auftretende Probleme mit der Software geboten. Weiterhin können über FTP entsprechende Updates frühzeitig geladen werden.

Auszüge aus der FAQ dürfen mit Quellenangabe ohne extra Genehmigung im FIDO-Netz und in den Newsgroups verbreitet werden.

Es ist nicht erlaubt Änderungen am Programm und der Dokumentation durchzuführen.


Woher bekomme ich das Programm und was gibt es noch so?

Die aktuelle Version des "Registry System Wizard" finden Sie unter http://www.winfaq.de.

Damit Sie nicht immer das ganze Programm herunterladen müssen, gibt es hier folgende Versionen:

Das komplette Programmpaket (ca. 9 MB), welches alle VB-Runtimemodule enthält.

Das Updatepaket (ca. 2,5 MB), welches nur die geänderte Datenbank und RSW.EXE-Datei enthält.

Wer das Programm einmal heruntergeladen und installiert hat, braucht nur noch das Updatepaket herunterzuladen, um damit die vorhandene Version auf die aktuelle Version zu aktualisieren.

Desweiteren wird es weiterhin die Hilfedatei-Versionen der WinFAQ geben.

Hier sind die Tipps genauer und ausführlicher beschrieben. Auch gibt es hier noch viele andere Funktionen und Infos, die im Registry System Wizard nicht zu finden sind.

winhlp.zip | Die Help-File Version
winchm.zip | Die CHM File Version
faqhtml.zip winfaq_tr.zp | Die HTML-Version Die WinFAQ als Tomeraider Version

Alle 4 Versionen sind vom Inhalt her indentisch, so dass sich jeder die Version raussuchen kann, die ihm am besten gefällt oder mit der er am besten umgehen kann.


Danksagungen

Modul Onlineupdate:

Thomas Krieger

Programmierung und Überarbeitung der MDB-Datei:

Peter Schmelz

Lektorat:

Friedhelm Hahne

Bereitstellung des RSW Forums und Pflege der RSW-Hilfe:

Ralf Kreutzmann

Englische Übersetzung von:

Jon Hogeslag

Bedanken möchte ich mich bei allen Betatestern, die mir beim Erstellen dieses Programmes geholfen haben, insbesondere bei:

Andreas Kästner

Burkhard Schulz

Björn Berg

Stephan Boos

Peter Friedmann


Versionshistory

Updateliste

Bei jedem Programm gibt es Fehler, leider auch in meinem Programm [image] .

Hier pflege ich eine Liste der gefundenen Fehler und der neuen Funktionen.

Ich bedanke mich bei allen, die mir Fehlermeldungen und Verbesserungvorschläge zugeschickt haben.

Für Fehler im RSW gibt es auch eine extra Fehlerliste

Version 1.6.0
Neu:

  • Es wurden neue Tipps hinzugefügt.

Version 1.5.9
Neu:

  • Es wurden neue Tipps hinzugefügt.

  • Es können jetzt neue Tipps über einen Wizard zu einer eigenen Tippdatenbank hinzugefügt werden (erste Test-Version, wird noch weiter überarbeitet).

Version 1.5.8
Neu:

  • Die Verlaufsansicht (Histroy) der durchgeführten Änderungen wurde überarbeitet:
    - Änderungen an der Registry und an INI-Dateien werden gespeichert
    - Geänderte Registrywerte können in eine REG-Datei exportiert werden
    - Alte Einträge können automatisch nach einer bestimmten Zeit gelöscht werden

  • Kleinere Fehler wurden behoben

Version 1.5.2

Neu:

  • Neue Tipps hinzugefügt

  • Erstellung der ADM-Files überarbeitet (Liste)

Version 1.5.1
Neu:

  • Neue Tipp hinzugefügt

  • Unter "Extras" -> "Registry durchsuchen..." habe ich jetzt wegen der großen Nachfrage ein löschen für die gefundenen Werte eingebaut. Aus Sicherheitsgründen wird aber verhindert, das wichtige Systemschlüssel gelöscht werden können (so wird z.B. ein löschen von HKLM\Software unterbunden).

  • Rubrik „Arbeitsoberfläche und Explorer“ -> „Startmenü“ neu aufgeteilt und sortiert

  • Neue Rubrik „Verbindungen ins Internet“ eingeführt. Hier werden jetzt alle Tipps zusammengeführt, die eine automatische Kommunikation ins Internet durchführen.

  • Tipps, welche für unterschiedliche Office Versionen einen Eintrag durchführen, erscheint jetzt oben eine Auswahlbox für die gewünschte Office Version

  • Zuweisungsbox für den Tipp: "In Outlook gesperrte Dateianhänge wieder anzeigen (Level1)" erstellt. Dadurch wird es jetzt einfacher die entsprechenden Endungen freizuschalten.

    Für RSW Registry Cleaner (Beta 0.1.1) - Nur für Testuser freigeschaltet:

  • Registry Cleaner kann nur noch mit administrativen rechten gestartet werden.

  • Registry Cleaner: Mit einem Wizard zur Führung angefangen.

Fehler:

  • Beim beenden wird das Programm nicht wieder neu gestartet

  • Einige Tipps überarbeitet

  • REG-Files wurden bei einigen Datentypen fehlerhaft erstellt. Die Erstellung der REG-Files wurde überarbeitet.

  • Fehler in der Anzeige entfernt

Version 1.5.0
Neu:

  • Neue Tipps hinzugefügt

  • Fehler in der Anzeige entfernt

Version 1.4.11
Neu:

  • Setup umgestellt:
    - Es wird beim Setup überprüft, ob MDAC und der JET-Provider installiert sind, wenn nicht wird ein Download bei Mircosoft angeboten
    - Setup ist jetzt auch in Englisch möglich
    - Die Sprache wird bei der Installation gespeichert und der RSW wird in der entsprechenden Sprache gestartet

  • Der RSW prüft jetzt auch schon zu Anfang ob MDAC und der JET-Treiber installiert sind.

  • Ein paar neue Tipps wurden hinzugefügt und einige Tipps wurden umgestellt und überarbeitet.

  • Online Update konnte mit Versionsnummer in der 3 Stelle nicht richtig umgehen und zeigte deshlab ein Fehlerhaftes Verhalten beim Update auf 1.4.10

  • Fehler bei der Anzeige von Tipps zur Farbumstellung (Text war verschoben)

Version 1.4.10
Fehler:

  • Durch einen Fehler bei der Rechteermittlung auf der Registry, konnten gemachte Einträge nicht mehr entfernt werden.

Version 1.4.9
Neu:

  • Allgemein:

  • Backup/Restore wurde umgestellt. Es werden jetzt auch die Registryeinträge der Dienstekonten gesichert. In jedem Backupverzeichnis wird eine Liste mit den gesicherten Dateien abgelegt (NT/2000/XP und 2003).

  • Wird der RSW nach einem Restor der Registry gestartet, werden die TEMP-Registrydateien automatisch gelöscht (NT/2000/XP und 2003).

  • Fehler bei der Rechteanzeige. Wurde der RSW unter einem Account gestartet, der nicht alle Rechte hatte Einträge zu ändern, war der Speicherbutton bei Keys die nicht vohanden waren immer freigeschaltet. Erst beim Speichern wurde eine Fehlermeldung angezeigt. Jetzt werden die Rechte auch hier sofort geprüft.

  • Für RSW Registry Cleaner (Beta 0.7) - Nur für Testuser freigeschaltet:

  • Icons eingebunden

  • Informationen werden zu Typlib-Einträgen angezeigt und die Einträge können jetzt auch gelöscht werden

  • Einträge auf die man keine Rechte hat, werden nicht gelöscht.

  • Tree wird nach dem löschen der Einträge neu aufgebaut

  • Interface wir jetzt auch nach fehlern durchsucht.

  • Registry Defrag Tool fertiggestellt

Version 1.4.8
Neu:

  • Allgemein:

  • Fehlermeldung von DC nicht ermittelt werden konnte.

  • Für RSW Registry Cleaner (Beta 0.6) - Nur für Testuser freigeschaltet:

  • Cleaner Fenster kann nicht mehr Min/Maximiert werden

  • Wird das Cleaner Fenster geschlossen bzw. auf Abbrechen geklickt, wird zum RSW Hauptprogramm zurückgekehrt

  • Scrollbalken sollte jetzt vollständig sichtbar sein

  • Key auf den die Rechte fehlen, werden jetzt in ROT angezeigt. Muss aber noch dran arbeiten, damit Sie dann beim löschen nicht benutzt werden (ist noch nicht alles fertig...)

  • Erste Version vom Registry Defrag Tool

Version 1.4.7
Neu:

  • Backup der Registry war bei einigen Rechnern nicht mehr möglich. Der Grund lag an der Bildung des Verzeichnisnamens. Hier ist es bei einigen Usernamen zu einem Fehler gekommen.

  • War die Toolbarleiste falsch sortiert, konnte es passieren, dass der RSW abstürzte und nicht mehr gestartet werden konnte. Die Werte werden jetzt auf gültige Bereiche überprüft und entsprechend angepasst.

Version 1.4.6
Neu:

  • Allgemein:

  • Das OCX cNumberBox wurde durch ein Benutzersteuerelement ersetzt, somit gibt es hier durch die Registrierung keine Probleme mehr.

  • Überarbeitete Tippdatei

  • Für RSW Registry Cleaner (Beta 0.5) - Nur für Testuser freigeschaltet:

  • Die Infobox wurde gelockt (man kann keinen Text mehr eintragen)

  • Einige Schlüsselt werden beim „Löschen“ nicht gelöscht:
    Der Grund ist der, dass es Schlüssel gibt, auf die selbst ein Administrator nur lesende rechte hat und deshalb der Schlüssel nicht gelöscht wird. Ich gebe jetzt erst mal bei diesen Schlüsseln eine entsprechende Meldung aus.
    Das diese Schlüssel nach einer Abfrage trotzdem gelöscht werden können, werde ich erst später Programmieren.

  • Erste Typelib -Auswertung wird angezeigt

  • Leere Einträge in der Sicherungsdatei
    Durch einen Fehler, wurden leere Schlüssel nicht in die Sicherungsdatei eingetragen.

Version 1.4.5
Neu:

  • Allgemein:

  • Der RSW kann jetzt auch im abgesicherten Modus gestartet werden

  • Habe die Kompilierung vom RSW geändert (darum auch ein Update aller DLLs). Dadurch soll das Programm stabiler laufen (hat man mir gesagt) und es ist auch kleiner geworden. Ich hoffe es gibt bei euch keine Fehler, bei mir ist der RSW erst abgestürzt, weil ich nicht alle DLLs ausgetauscht hatte, dass sollte jetzt aber laufen.

  • Für RSW Registry Cleaner (Beta 0.4) - Nur für Testuser freigeschaltet:

  • Fehlerbehandlung eingebaut, das Programm sollte jetzt nicht mehr abstürzen, sondern eine Fehlermeldung ausgeben

  • Debugausgabe eingebaut, wird der RSW im Debugmodus gestartet, erzeugt der Cleaner ein ausführliches LOG (wichtig für mich zur Fehleranalyse)

  • Der Tree kann jetzt auch mit der Maus durchgeblättert werden

  • Falsche Anzahl der gefundenen Fehler unter „COM und AktivX Objekte“:
    Hier wurden nur die als Fehler gezählt, wo auch der gesamte Zweig gelöscht wurde. Wenn nur ein Teilzweig gelöscht wurde, dann wurde das nicht als Fehler gezählt…

  • Es gibt im Tree jetzt erst einen Rootknoten „Fehlerhafte Einträge“:
    Dieser Konten gibt eine Gesamtübersicht aus. Wird kein Fehler gefunden ist nur dieser Konten mit einem entsprechenden Text vorhanden.
    Später werden hier rüber auch gleich automatisch alle Einträge zum löschen markiert. Wichtig, da sich die unerfahrenen Leute ja nicht erst noch Gedanken darüber machen sollen ob das jetzt richtig so ist… Bis der RSW Cleaner aber so stabil ist, brauche ich wohl doch mehr Zeit als ich dachte….

  • Der Button „Delete“ wird jetzt auch wieder ausgeschaltet, wenn kein Eintrag zum löschen vorhanden sind.

  • Dateiname für Backupdatei
    Der Dateiname der Backupdatei wird jetzt anders gebildet:
    1. Tag, Monat und die Zeit werden immer zweistellig angezeigt
    2. Es wird zuerst das Jahr - Monat und dann der Tag ausgeben (Vorteil beim sortieren…)
    3. Die einzelnen angaben werden durch einen – getrennt (Übersichtlicher)
    Beispiel: Backup_2004-02-01_13-14-41.REG

  • Es gibt zwar einen Eintrag „Typelib Einträge untersuchen“, aber das ist noch nicht fertig und wird auch noch nicht ausgewertet, also nicht wundern. Später wird das auch unter „COM und AktivX Objekte“ fallen, ist nur erst mal damit ich es besser testen kann.

Version 1.4.4

Anpassungen:

  • WinFAQ mit der RSW-Version abgeglichen

  • Fehler in einigen Tipps behoben

  • Beschreibungen bei Aktivieren/Deaktivieren verständlicher beschrieben

Version 1.4.3

Neu:

  • Ein paar neue Tipps

Fehler behoben:

  • Anzeige in rechten Fenster nicht immer vollständig

  • Enter bei der Passwortabfrage startet jetzt das Programm

  • Löschen ist in der Softwarelist nicht möglich, wenn allgemeines löschen unter Optionen nicht aktiviert wurde

Version 1.3.20 - Beta

Neu:

  • Online Update für die Tippdatenbank eingebaut. Die Tippdatenbank muss jetzt bei Änderungen nicht immer ganz neu runtergeladen werden, dadurch ist es jetzt auch möglich schnell neue Tipps und Updates rauszubringen.

Fehler behoben:

  • Gleiche Fehlermeldungen wurden immer mehrfach angezeigt

  • In der Suchfunktion wurden Tipps mehrfach angezeigt und die Suche dauerte ungewöhlich lange

  • Vollbildmodus wurde beim Beenden vom RSW nicht richtig gespeichert

  • Splash-Screen wurde beim Starten nicht immer in der Bildschirmmitte angezeigt

Version 1.3.18 - Beta

  • Policy Tipps für HKLM und HKCU werden jetzt extra angezeigt

  • Neue Tipps hinzugefügt

  • Sortierung der Tipps geändert

Version 1.3.16 - Beta

  • Fehler im Tipp: "Einstellungen der RamDisk verändern" (falscher Registrypfad in der Datenbank)

  • Fehler im Tipp: "Pfad beim Verknüpfungen ausblenden" (es wurde nicht der richtige Pfad zur neuen Icondatei in der Registry eingetragen)

Version 1.3.14 - Beta

  • Fehler: Absturz beim Tipp "Desktop Funktion ändern (XMouse/Tooltips usw.)" behoben

  • Erkennung von Windows Server 2003 eingebaut

Version 1.3.13 - Beta

  • Erste Version mit Sprachendatei für Englisch

Version 1.3.12 - Beta

  • Bei Policy-Werten wird jetzt zwischen HKCU und HKLM unterschieden. Es werden immer beide Werte angezeigt, auch werden ADM-Dateien jetzt mit beiden Werten erstellt.

Version 1.3.11 - Beta

  • Assistent in der Suchfunktion ausschalten

Version 1.3.10 - Beta

Durch die Umstellung auf den neuen Datenbankaufbau sind mir kleine Fehler unterlaufen die folgende Tipps betroffen haben:

  • Fehler beim Tipp: Registrierte Programmeinträge unter Uninstall (RSW stürzte ab)

  • Fehler beim Tipp: Nicht gebrauchte DLL sofort aus dem Speicher entfernen (Infotext fehlte)

  • Fehler beim Tipp: Swap-Verhalten beeinflussen (Datensatz fehlte)

  • Fehler beim Tipp: Öffnen/Speichern Dialog anpassen (RSW stürzte ab)

  • Fehler beim Tipp: Icons der Systemsteuerung ausblenden (es wurde nichts angezeigt)

  • Fehler beim Tipp: Internet Explorer ohne Cache benutzen

  • Fehler beim Tipp: Kontextmenü "Eigene Dateien" bearbeiten (RSW stürzte ab)

Version 1.3.9 - Beta

Neu:

  • Toolbarleiste wurde um Funktionen erweitert

  • Steuerbox "Aktuelle Einstellungen" kann ausgeblendet werden

  • Spracheinstellung wurde eingeführt (Deutsch/Englisch)

  • Es wurden neue Tipps in die Datenbank eingetragen

Geändert:

  • Fehler in der Datenbankansteuerung entfernt

  • Fehler aus Tipps entfernt

Version 1.3.7 - Beta

Neu:

  • Es können jetzt eigene Datenbanken mit Tipps geladen werden

Geändert:

  • Datenbank umbenannt von REGDaten.MDB in RSWDaten.MDB

  • Suchfunktion überarbeitet und auf die neue Datenbank umgestellt

  • History.txt und Favoriten.txt werden jetzt unter den Namen der Datenbank abgelegt.
    Für die Standarddatenbank RSWDaten.MDB lautet jetzt der Name:
    RSWDaten Histroy.txt
    RSWDaten Favorite.txt

Version 1.3.6 - Beta

Neu:

  • Suchen in der Registry ist möglich

Version 1.3.5 - Beta

Neu:

  • Neue Tipps in die Datenbank eingebunden

Version 1.3.4 - Beta

Neu:

  • Bildschirmanzeige wurde überarbeitet

  • Einführung einer extra Datei für die Sprach- und Grafiganteile im RSW (rswger.rd)

Version 1.3.3

Neu:

  • Neue Tipps wurden in die Datenbank eingetragen

Fehler:

  • Fehler im Tipp "Outlook minimiert im System-Tray starten" behoben.
    Fehlerhafter Registrykey

  • Fehler im Tipp "In einen neuen Prozess browsen" behoben.
    Fehlerhafter Registrykey

  • Tipp: Anzeige des Textes während des Scrollens auch bei Word 97
    Falscher Datentyp

  • Tipp: Nicht gebrauchte DLL sofort aus dem Speicher entfernen
    Fehlerhafter Registrykey

  • Anzeige: Das Fenster wurde nicht richtig vergrößert, wenn man auf Vollbild geklickt hat.

Version 1.3.1

Update:

  • Bei einigen Windows Verisonen gab es eine alte "TabCtl32.ocx", dadurch konnte das Options - Menü nicht geöffnet werden und der RSW hat sich beendet. Bei dieser Verison ist diese OCX-Datei mit Dabei.

Version 1.3

Neu:

  • Neue Tipps wurden in die Datenbank eingetragen

Fehler:

  • Betriebssystemerkennung von Windows 95 wurde verbessert

  • Fehler beim erstellen von ADM-Dateien wurde entfernt. Hier wurden bei einigen Tipps nicht alle Werte in die ADM-Datei geschrieben

  • Die Fenster im RSW wurden bei einigen Leuten zu klein angezeigt und konten nicht vergrößert werden, der Fehler sollte jetzt behoben sein (kann ich selber leider nicht testen da hier der Fehler nie aufgetreten ist)

  • Einige alte Tipps wurden überarbeitet

  • Abbrechen beim speichern von ADM-Datei war nicht möglich, ADM Datei wurde trotzdem gespeichert

Version 1.2.25

Neu:

  • Neue Tipps wurden in die Datenbank eingetragen

Fehler:

  • Auf schnellen bzw. Rechnern mit zwei Prozessoren ist der RSW teilweise beim starten abgestürzt

Version 1.2.24

Fehler:

  • Einträge in der Backupliste konnten nicht Fehlerfrei gelöscht werden

  • Die USER-Namen werden jetzt unter allen Betriebssystemen fehlerfrei ausgelesen

Version 1.2.23

Fehler:

  • Backup berücksichtigt nun auch unter Windows 9x/ME angelegte Benutzerkonten

  • Fehler im Tipp "Fehlermeldung: Zu wenig Stackseiten" behoben

Version 1.2.22

Fehler:

  • Backup der Registry unter Windows 9x/ME wurde zwar durchgefüht aber nicht in der Liste eingetragen und dadurch fehlerhaft beendet.

Version 1.2.21

Neu:

  • Neue Tipps wurden in die Datenbank aufgenommen

  • Die Standardpfade für das Backupverzeichnis können jetzt verändert werden

  • Das Umschalten des Baums zwischen den Tipps läuft jetzt schneller

  • Der Registrypfad eines Tipps kann unter "Keyinfo" automatisch in die Zwischenablage kopiert werden

  • Erstellen von ADM-Dateien wurde erweitert

Fehler:

  • Einlesen der Boot.INI war nicht möglich, wenn andere BS als erstes eingetragen waren

  • Fehler in der Suchfunktion: Wurde ein Tipp gefunden, der im Baum nicht vorhanden war bzw. wurde auf Abbrechen geklick, wurde eine Fehlermeldung ausgegeben.

  • Pfad zur System.INI und Win.INI wurde bei Windows 9x falsch ermittelt

  • Erstellen eines Registrybackups war nicht möglich, wenn kein deutsches Datumsformat eingestellt war.

Version 1.2.20

  • Wurde nur an Betatester rausgegeben

Version 1.2.19

Neu:

  • Erstellen von ADM-Dateien

  • Neue Tipps in die Datenbank eingebunden

  • Ausgewählte Tippgruppe (Betriebssystem) wird beim Beenden gespeichert und beim Neustart wieder als Standard geöffnet.

Fehler:

  • Fehler beim Schreiben von REG_BINARY Werten bei einigen Tipps

  • Das Anzeigen von Tipps, die über Suchen gefunden wurden, funktionierte nicht, wenn die Anzeige nicht auf "ALLE" stand.

Version 1.2.18

Neu:

  • Sichern und Wiederherstellen der Registry (Backup/Restore)

  • RSW Registry Browser (erste Beta)

  • Ein paar neue Tipps in die Datenbank eingebunden

Fehler:

  • Einige kleinere Anzeigefehler wurden beseitigt

Version 1.2.14

Neu:

  • Alle Einstellungen der BOOT.INI (Windows NT/2000) können jetzt bearbeitet werden.

  • Löschen von INI-Einträgen ist möglich

  • Ein paar neue Tipps in die Datenbank eingebunden

Fehler:

  • Einige kleinere Anzeigefehler wurden beseitigt

  • Der Tipp "Autostartfunktion für unterschiedliche Laufwerke einstellen wurde geändert. Aufgrund der vielen Mails (danke an alle, die mir diese Meldung zugeschickt haben), hat die Auswertung ergeben, dass bei den meisten dieser Wert als REG_BINARY in der Registry vorhanden ist. Ich habe den Datentyp deshalb auf REG_BINARY in der Datenbank geändert.

Version 1.2.13

Neu:

  • Jetzt können auch die Tipps mit dem RSW bearbeitet werden, die sich auf INI-Dateien beziehen. So können jetzt z.B. die Einstellungen der MSDOS.SYS über den RSW verändern werden (Weitere werden in der nächsten Version folgen).

  • Etliche neue Tipps wurden in die Datenbank aufgenommen

Fehler:

  • Bei einigen Tipps ist der Fehler aufgetreten, dass sie trotz der Deaktivierung in Windows weiterhin aktiv geblieben sind. Das ist z.B. bei den Policy-Einstellungen für den Active-Desktop der Fall gewesen. Erst wenn dieser Wert aus der Registry gelöscht wurde, war die Funktion auch wirklich deaktiviert. Aus diesem Grunde werden jetzt Einträge, die normalerweise nicht in der Registry vorhanden sind, bei der Deaktivierung auch wieder gelöscht.

Version 1.2.12

Fehler:

  • Beim Remote Zugriff auf einen anderen Rechner im Netzwerk wurde meist auf das Profil ".Default" zugegriffen und nicht auf das Profil des Anwenders. Jetzt kann zwischen ".Default" und SID des Anwenderprofiles ausgewählt werden (auch auf lokalen Rechnern).
    BS: Windows NT/2000

  • In der History-Liste wurde zwar abgespeichert ob die Einstellungen lokal oder auf einem anderen Rechner verändert wurden, wollte man aber eine Veränderung von einem anderen Rechner wieder rückgängig machen, wurde das nicht auf dem entsprechenden Rechner, sondern auf dem aktuellen Rechner durchgeführt.
    BS: Windows NT/2000

  • Jetzt werden auch BIT-maskierte Einstellungen aufgeschlüsselt und richtig angezeigt. In der alten Version wurde der Eintrag unter "X-Mouse Funktion aktivieren" nicht richtig angezeigt. Wenn Sie diese Funktion benutzt haben, sollten Sie sich die Einträge jetzt noch mal anzeigen lassen.
    BS: Windows NT/2000

  • Der RSW ist bei einigen Benutzern beim Starten mit einer Fehlermeldung abgestürzt. Diesen Fehler konnte ich erst nicht nachstellen und nur durch Hinweise einiger Anwender glaube ich diesen Fehler jetzt beseitigt zu haben. Grund war ein kleiner Fehler bei der Überprüfung, ob der Anwender Administrative-Rechte besitzt. (Auch wenn die Anzeige bei "Lade Datenbank" abgebrochen ist, war das Programm schon weiter, auch diese Anzeige habe ich jetzt etwas genauer aufgegliedert).
    BS: Alle

Version 1.2.11

Fehler:

  • Beim Klick auf NEU ist der RSW abgestürzt, wenn die Ländereinstellung unter Windows auf "Deutsch [Schweiz]" eingestellt war, dieser Fehler ist jetzt behoben. Dank an den Schweizer für den Hinweis.

Version 1.2.1

Neu:

  • Bearbeiten von Kontextmenüs ist möglich

  • Umgestellt auf MDAC Datenbankzugriff (Erleichtert das Einbinden des geplanten Datenbankeditors)

  • Fehler beseitigt

  • Neue Tipps in die Datenbank eingebunden

  • Viele Registry Werte werden jetzt ohne Neuanmeldung aktiv (dynamisches Nachladen beim Verändern)

  • Sie können sich jetzt anzeigen lassen, welche Tipps neu hinzugekommen sind (Neu -> Sortiert nach Datenbank-Version)

  • Erstellen von Windows 2000 REG-Files wird unterstütz

  • Parameterübergabe beim Start wird unterstützt (RSW /?) zeigt die aktuellen Parameter (zur Zeit nur für Windows NT und 2000 interessant).

Version 1.1.1

Fehler:

  • Bei der Erstellung eines REG-Files wurde nicht berücksichtigt, dass innerhalb eines Tipps unterschiedliche Registrypfade vorkommen können. So wurde z.B. für den Tipp "Anmeldebildschirm ohne Eintrag" ein fehlerhaftes REG-File erstellt

Version 1.1.00

Neu:

  • Erste nicht Beta-Version

  • Aktuelle Registryeinstellungen können in einem REG-File abgespeichert werden

  • History Funktion. Daduch können Sie alle Änderungen auch später nachvollziehen und haben die Möglichkeit, wieder den alten Wert herzustellen

  • Sie können sich eine eigene Favoriten-Liste mit Ihren oft gebrauchten Einstellungen anlegen

  • Unter Windows NT und 2000 werden jetzt auch die Registrywerte angezeigt, auf die Sie nur Leseberechtigung haben

Version 1.0.23

Fehler:

  • Auf Rechnern ohne Netzwerk konnte es vorkommen, dass keine Registryschlüssel mehr angezeigt wurden und auch keine angelegt werden konnten (gerade bei Windows 95/98/ME). Das lag daran, dass ich für den Registryzugriff einen Dienst benutzt habe, der bei Rechnern ohne Netzwerk nicht vorhanden war. Jetzt frage ich das vorher ab und greife bei Änderungen am lokalen Rechner auch direkt auf die Registry zu.

  • In der Vollversion habe ich das Setupprogramm überarbeitet. Hier wurde als Installationsverzeichnis immer "C:\Programme\Registry System Wizard\Registry System Wizard\" vorgeschlagen, das habe ich jetzt auf "C:\Programme\Registry System Wizard\" geändert.

Version 1.0.22

Neu:

  • Einstellungen können in einem REG-File abgespeichert werden

  • Eine Suchfunktion wurde eingebaut

  • Fehler in einigen Tipps wurden beseitig

Version 1.0.19

Neu:

  • Registrywerte können über das Netzwerk verändert werden (noch im Test)

Version 1.0.18

Fehler:

  • Animation der Fenster beim Minimieren/Maximieren ausstellen
    Fehlerhafer Registrykey
    -> HKEY_CURRENT_USER\Control Panel\Desktop\WindowsMetrics (falsch)
    -> HKEY_CURRENT_USER\Control Panel\Desktop\WindowMetrics (richtig)

  • Gleichzeitige Verbindungen zu einem Server mit dem IE erhöhen
    Fehlerhafter Registrykey
    -> HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\InternetSettings (falsch)
    -> HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings (richtig)

  • Zugriff auf Samba Server nicht möglich
    Der angegebene Registrykey war nur für NT, für Windows 98 sieht der Eintrag anders aus:
    -> HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Services\ Rdr\ Parameters (NT/2000)
    -> HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Services\ VxD\ Vnetsup (98)

  • Anzeigen der Versionsnummer auf dem Desktop
    Hier konnte die Anzeige der Versionsnummer nicht mehr ausgeschaltet werden. Der Fehler war, dass ich zum Ausblenden den Eintrag auf 0 gesetzt habe, Windows aber ein NO will und darum den Wert nicht beachtet hat.

  • Desktop erst laden, wenn das Loginscript abgearbeitet ist
    Hier hatte ich den falschen Datentyp angegeben, der richtige Datentyp ist REG_DWORD


Was kann das Programm?

Dieses Programm ist für alle gedacht, die gern einige Tipps aus der WinFAQ nutzen möchten, sich aber nicht so gern durch die Registry von Windows hangeln wollen.

Tipps aus der WinFAQ, die Änderungen an der Registry beschreiben, können mit diesem Programm durch einfaches Auswählen der möglichen Optionen durchgeführt werden.

Des weiteren zeigt das Programm die gerade aktuellen Einstellungen an.

Welche Funktionen sind eingebunden?

  • Anzeigen und Bearbeiten von Registryschlüsseln, wobei die Einträge ausführlich beschrieben werden.

  • Ändern der Registry über das Netzwerk unter Windows NT4/2000/XP/2003 (Details)

  • Automatisches Erstellen einer REG-Datei anhand der aktuellen Einstellung (von einzelnen Tipps oder von selbst zusammengestellten Tippgruppen)

  • Suchfunktion nach Stichworten in der Tippliste

  • Automatische Erstellung einer Verlaufs-Liste der durchgeführten Änderungen mit der Möglichkeit, die Änderung wieder rückgängig zu machen (Details)

  • Favoriten Liste, in der Sie Ihre oft verwendeten Tipps ablegen können. Diese Datei wird als "Favoriten.txt" auf Ihren Rechner abgelegt und kann somit leicht gesichert werden. (Details)

  • Unter Windows NT und 2000/XP/2003 wird angezeigt, welche Rechte Sie auf diesem Schlüssel haben. Bei Nur-Lese-Rechten werden die aktuellen Einstellungen angezeigt und die Buttons zum Verändern ausgeblendet.

  • Sichern und Wiederherstellen der Registry (Details)

  • RSW Registry Browser

  • Erstellen von ADM-Dateien (Details)

  • Erstellen von REG-Dateien

  • Durchsuchen der Registry nach Stichworten. (Details)

  • Speichern und Löschen der Suchergebnisse

  • Update-Funktion im Programm integriert (Details)

  • Exportieren der Änderungen die Sie mit dem RSW an der Registry durchgeführt haben (Details)

  • Navigation per <Alt + Buchstabe>

  • Hinzufügen von neuen Tipps in einer eigenen Datenbank über einen Wizard


Programmaufbau

Wenn Sie das Programm starten, sehen Sie folgende Oberfläche:

Auf der linken Seite finden Sie ein Auswahlmenü wie Sie es schon aus der Hilfedatei der WinFAQ kennen.

Sie können hier aber zwischen unterschiedlichen Ansichten wählen:

Nur Tipps eines bestimmten Betriebssystems anzeigen (wie Sie es oben im Bild sehen)

Sortiert nach Tippgruppen

Sortiert nach Version (neu)

Sortiert nach Alphabet

Auf der rechten Seite sehen Sie zwei Fenster. Im oberen Fenster werden die Einstellmöglichkeiten des gerade ausgewählten Tipps angezeigt.

Jeder einzelne Registrywert ist dabei in einem Kasten eingeschlossen, der zwei mögliche Bezeichnungen haben kann:

[Registry Wert nicht vorhanden]

[Registry Wert vorhanden]

Außerdem wird Ihnen noch angezeigt, ob Sie auf den Schlüssel nur Lese- oder auch Schreibrechte haben.

Genaueres dazu lesen Sie bitte unter: Anzeigemöglichkeiten eines Registrywertes nach.

In der unteren Hälfte des Fensters wird eine Kurzinformation zu dem aktuellen Tipp angezeigt.

Hier wird kurz beschrieben, was Sie oben einstellen können und was Sie eventuell beachten sollten.

Unter diesem Informationskasten finden Sie den Button "Hilfe". Wenn Sie auf diesen Button klicken, wird der Tipp aus der WinFAQ-Hilfedatei aufgerufen, wo Sie genauere Informationen zu diesem Tipp finden.

Mit welcher Hilfedatei-Version Sie arbeiten möchten, können Sie unter "Hilfedatei" im Optionenmenü einstellen.


Menü Datei

Das Menü Datei

Datenbank laden:

Hier können Sie die RSW DB laden, wenn Sie zuvor an einer eigenen Datenbank gearbeitet haben oder eine

Andere DB laden, um eigene Tipps zu erstellen.

Sie können die Registry Sichern/Herstellen! Eine detaillierte Beschreibung dazu finden Sie hier.

Sie können die Registry über Netzwerk bearbeiten auswählen, um die Registry eines anderen Rechners in Ihrem LAN oder Ihrer Domäne bearbeiten. Eine ausführliche Beschreibung zur Vorgehensweise finden Sie hier.

Über Beenden schließen Sie dieses tolle Programm.


Menü Bearbeiten

Das Menü Bearbeiten

Mit Wert speichern, übernehmen Sie Änderungen an einem gerade bearbeiteten Tipp.

Mit Wert löschen, entfernen Sie die Werte aus der Registry. Diese Funktion ist nur verfügbar, wenn Sie hier die entsprechende Opion aktiviert haben.

Mit einem Klick auf Standard stellen Sie den Windows Original-Zustand für diesen Schlüssel wieder her.

Über Verlauf der Änderungen können Sie kontrollieren, welche Schlüssel und Werte Sie bereits mit dem Registry System Wizard bearbeitet haben.

Key Info gibt ausführliche Informationen über den Registry-Wert aus.

Ein Klick auf Freigegeben für die Betriebssysteme zeigt Ihnen an, für welche Betriebssysteme der gerade angezeigte Tipp freigegeben ist.

Weitere Infos zum Tipp öffnet die WinFAQ-Hilfe-Datei mit dem ausgewählten Tipp.

Der Eintrag Profil zum Bearbeiten auswählen ist sehr interessant, wenn Sie auf Ihrem Computer mehrere Benutzerkonten angelegt haben. Sie können hier das jeweilige Benutzerkonto wählen, um die Einstellungen für das entsprechende Konto zu ändern.

Hinweis:

Der Benutzer muss sich aber min. einmal angemeldet haben, da sonst das Profil noch nicht existiert

Außerdem haben Sie hier die Möglichkeit das Default User-Profil anzupassen. Diese Einstellungen betreffen dann alle neu angelegten Benutzer, die noch kein Profil besitzen.


Menü Ansicht

Das Menü Ansicht

Hier können Sie das Erscheinungsbild des Registry System Wizard anpassen

Durch das Entfernen des Hakens bei Favoriten Liste anzeigen, blenden Sie die Favoriten-Symbolleiste aus.

Die Buttons für das Hinzufügen und Entfernen von Favoriten werden dann automatisch in die Standard-Symbolleiste verschoben.

Durch das Entfernen des Hakens bei Favoriten Buttonliste, blenden Sie die Buttons für das Hinzufügen und Entfernen von Favoriten aus der Favoriten-Symbolleiste aus.

Durch Deaktivierung des Eintrags Steuerbox "Aktuelle Einstellungen" anzeigen, blenden Sie die Buttons unter jedem Tipp aus.

Wenn Sie bei den Symbolleisten auf den Beschreibungstext verzichten möchten und kleine Symbole bevorzugen, dann entfernen Sie einfach den Haken vor Button Icons\Icons mit Text.


Menü Tipps

Das Menü Tipps

Mit REG File vom aktuellen Tipp erstellen können Sie vom aktuell geöffneten Tipp eine REG-Datei erstellen. Es öffnet sich ein Dialog, indem Sie Speicherort und Namen der REG-Datei eingeben. Es wird der aktuell in der Registry befindliche Wert in die REG-Datei geschrieben.

Mit ADM File vom aktuellen Tipp erstellen können Sie vom aktuell geöffneten Tipp eine ADM-Datei erstellen. Es öffnet sich ein Dialog, indem Sie Speicherort und Namen der ADM-Datei eingeben. Es wird der aktuell in der Registry befindliche Wert in die ADM-Datei geschrieben.

Mit Tipp zur Registry Liste hinzufügen fügen Sie den Tipp zu einer Liste hinzu. Dieses ist praktisch, wenn Sie ein System einrichten und die gleichen Einstellungen auf einem anderen System vornehmen möchten.

Sie fügen einfach nach jeder Änderung den Tipp in die Registry-Liste ein und nachdem Sie Ihr System eingerichtet haben, klicken Sie auf Registry Liste speichern.

Mit Tipp zur ADM-File Liste hinzufügen fügen Sie den aktuell geöffneten Tipp zu einer Liste hinzu. Dieses ist praktisch, wenn Sie ein System einrichten und die gleichen Einstellungen auf einem anderen System vornehmen möchten oder wenn Sie domänenweite Einstellungen auf einem Einzelplatzrechner zusammenstellen wollen.

Sie fügen einfach nach jeder Änderung den Tipp in die ADM-Liste ein und nachdem Sie Ihr System eingerichtet haben, klicken Sie auf ADM-File Liste speichern.

Hinweis:
Sowohl die Registry Liste als auch die ADM File-Liste werden bei Programm-Ende geleert. Wenn Sie also mehrere Anläufe zum Einrichten des Systems benötigen, dann müssen Sie die Registry Liste bzw. die ADM-File-Liste jeweils vor dem Beenden des Registry System Wizard speichern.


Menü Extras

Das Menü Extras

Mit einem Klick auf Systeminfo bekommen Sie die Basisinformationen zu Ihrem Betriebsystem angezeigt.

Mit Regedit und Regedt32 starten Sie den Windows-Registrierungseditor.

Mit dem RSW Registry Browser können Sie durch die Registry browsen.

Mit Registry durchsuchen... suchen Sie nach bestimmten Strings in der Registry.

Sie können in dem Ergebnis mehrere Ergebnisse markieren, exportieren und auch löschen.

Die RSW Datenbank durchsuchen Sie, wenn Sie nach einem bestimmten Tipp suchen wollen.

Sie haben hier umfangreiche Suchmöglichkeiten zur Verfügung mit denen Sie die Suche einschränken können.

Ein Klick auf Optionen öffnet das Optionen-Menü.


Menü Favoriten

Das Menü Favoriten

In diesem Menü verwalten Sie Ihre Registry System Wizard-Favoriten.

Beim Klick auf Favoriten hinzufügen wird der aktuell geöffnete Tipp in die Favoriten aufgenommen.

Mit Favoriten verwalten können Sie Ihre Favoriten überprüfen und ggf. Einzelne auch löschen.

Unter Favoriten öffnet sich ein Menü, indem alle Ihre Favoriten aufgelistet sind.


Menü Programme

Das Menü Programme

Über das Menü Programme können Sie einige Windows-Dienstprogramme aufrufen.


Menü Update

Das Menü Update

Über das Menü Update können Sie Ihren Registry System Wizard "online" aktualisieren.

Per Online nach RSW Update suchen, suchen Sie nach einer neuen Version des Registry System Wizard und per Online nach Datenbank Update suchen suchen, suchen Sie nach einer neuen Version der Datenbank.

In beiden Fällen erscheint folgender Dialog:

Klicken Sie auf weiter

Es wird dann eine Verbindung zum Update-Server aufgebaut und wenn Updates vorhanden sind, bekommen Sie das wie folgt angezeigt.

Klicken Sie zum Aktualisieren des Registry System Wizard oder der Datenbank auf Weiter oder um nicht zu aktualisieren auf Abbrechen.

Nach vollendeter Aktualisierung des Registry System Wizard dürfen Sie auf Fertig klicken und nach einem Neustart des Registry System Wizard ist Ihr Programm wieder aktuell.


Menü Hilfe

Das Menü Hilfe

Über das Hilfe Menü-gelangen Sie zur Registry System Wizard-Hilfe und auch zur WinFAQ-Hilfe-Datei.

Außerdem zeigt Ihnen der Registry System Wizard bei einem Klick auf Info seine Credits an und im Menü Internet bekommen Sie wichtige Links zur WinFAQ-Homepage, zum RSW-Forum und zum WinFAQ-Shop.


Allgemein

Allgemeine RSW Einstellungen

Keine Zeitverzögerung beim Start vom RSW (ca. 20 sec.)

Wenn Sie diese Funktion aktivieren, wird das Infofenster beim Start des Programmes nicht nehr angezeigt.

Ich gehe mal davon aus, dass das natürlich keiner machen möchte, weshalb standardmäßig diese Funktion auch nicht aktiviert ist.

Soundausgabe beim Klick auf Buttons

In welchem Format soll der Tipp abgespeichert werden?

Wählen Sie hier Standard-Format (für alle Windows-Versionen), wenn Sie exportierte Registry-Strings unter allen Windows-Betriebssystemen nutzen möchten.

Wählen Sie hier Neues Format (ab Windows 2000), wenn Sie exportierte Registry-Strings nur unter Windows 2000/XP/2003 nutzen möchten.

Betriebssystem Überprüfung aktiviert

Wenn Sie diese Funktion aktivieren, wird die Freigabe für die Tipps nicht mehr beachtet. Wenn also ein Tipp nur für Windows 95 und 98 freigegeben wurde, dann können Sie normalerweise nicht auf diesen Tipp unter einem anderen Betriebssystem zugreifen.
Da ich zeitlich nicht die Möglichkeit habe, einen Tipp unter allen Betriebsystemen zu testen, gebe ich sie nur für die frei, wo ich weiß, dass sie da auch ohne Probleme funktionieren.

Sa Microsoft schneller neue Betriebssysteme herausbringt, als ich alles überprüfen kann, habe ich mich entschieden, diese Möglichkeit der Deaktivierung zu ermöglichen.
So können alle, die sich auskennen oder gern rumprobieren, selber testen, ob dieser Tipp auch unter ihrem Betriebssystem läuft.

Dazu eine Bitte:
Sollte jemand einen Tipp testen und feststellen, dass er auch unter einem Betriebssystem läuft, für das der Tipp nicht freigegeben wurde, dann möge er mir doch bitte eine Mail mit der Überschrift und der Bezeichnung des Betriebssystems senden, damit ich dieses Betriebssystem in der Datenbank für diesen Tipp freischalten kann.

Löschen von Registryschlüsseln ermöglichen

Hier können Sie den Button "Löschen" aktivieren. Wenn Sie diese Funktion einschalten, wird Ihnen zu jedem Registry-Schlüssel die Möglichkeit angeboten, diesen Wert aus der Registry zu löschen.

Standardmäßig ist diese Funktion deaktiviert, um das versehentliche Löschen von Werten zu vermeiden. Sie sollten die Funktion nur aktivieren, wenn Sie genau wissen, dass Sie diesen Wert löschen dürfen, ohne die Funktion von Windows zu beeinträchtigen.


Hilfedatei

Hier können Sie einstellen, mit welcher Hilfedatei-Version Sie lieber arbeiten möchten bzw. welche unter Ihrem Betriebssystem läuft.

Standardmäßig wird das neue CHM-Hilfedatei-Format mitgeliefert, weshalb das auch die Standardauswahl ist.

Sie können sich aber jederzeit von der Homepage die andere Hilfedatei herunterladen und mit dieser Einstellung dann den Aufruf der "alten" HLP-Hilfedatei aktivieren.


Passwort

Hier können Sie ein Passwort für den Registry System Wizard eingeben, um Ihre Einstellungen vor unbefugten Anwendern zu sichern.


Verzeichnisse

Hier können Sie die Verzeichnisse des Registry System Wizard anpassen

Im Ablageverzeichnis für die Verlaufsliste werden alle Ihre Änderungen, die Sie mit dem Registry System Wizard durchgeführt haben, in der Datei: RSWDaten History.txt gespeichert.

Im Ablageverzeichnis für die Favoritenliste werden alle Ihre Favoriten, die Sie mit dem Registry System Wizard angelegt haben, in der Datei: RSWDaten Favorite.txt gespeichert.

Im Ablageverzeichnis für das Registry-Backup werden alle Ihre Registry-Backups, die Sie mit dem Registry System Wizard angelegt haben, gespeichert.


Sprache

Hier können Sie die Sprache des Registry System Wizard von Englisch auf Deutsch und umgekehrt umstellen.

Die Sprachänderung wirkt sich nur auf die Programmoberfläche und nicht auf die Tipps aus.

Es werden noch Leute gesucht, die bei der Übersetzung helfen wollen.


Tabreiter

Hier können Sie die für Sie unwichtigen Betriebssysteme (Tabreiter) aus dem Registry System Wizard ausblenden.

Das ist sehr praktisch, da es dann deutlich übersichtlicher aussieht!


Verlauf

Hier können Sie die History-Funktion konfigurieren

Sie können hier konfigurieren, wie lange die History aufgehoben wird und welche Werte in das Reg-File geschrieben werden.

Alter Wert sichert den Original-Wert, der vor der Änderung mit dem RSW in der Registry stand. Es handelt sich dabei nicht um den Windows Standard-Wert. Haben Sie vor der Änderung mit dem RSW manuelle Änderungen in der Registry durchgeführt, werden diese als Alter Wert gespeichert.

Neuer Wert sichert die Änderung, die Sie mit dem RSW durchgeführt haben in das REG-File.

Aktueller Wert sichert den aktuell in der Registry befindlichen Wert in eine REG-Datei. Dieser Wert kann vom Neuen Wert abweichen, wenn Sie manuelle Änderungen an der Registry durchgeführt haben, nachdem Sie den Wert mit dem RSW geändert haben.


Anzeigemöglichkeiten eines Registrywertes

Zu jedem einzelnen Registrywert wird auf der rechten Seite eine Auswahlmöglichkeit angeboten, die sich je nach Art des Tipps unterscheiden kann:

- Aktivieren/deaktivieren

- Texteingabebox

- Auswahlbox

- Pfad/Dateiauswahl

usw.

Dabei wird jeder Registrywert in einem extra Kasten dargestellt. Dieser Kasten kann zwei Bezeichnungen haben:

[Registry Wert nicht vorhanden] (in der Farbe ROT)

Das bedeutet, dass dieser Wert zur Zeit nicht in der Registry eingetragen ist. Das kann bei vielen Werten vorkommen. Wenn ein Wert in der Registry nicht vorhanden ist, wird von Windows die Standardeinstellung benutzt.

[Registry Wert vorhanden] (in der Farbe BLAU)

Der Registrywert ist in der Registry vorhanden und Sie sehen gerade die aktuelle Einstellung auf Ihrem Rechner

Außerdem werden Ihre Zugriffsrechte auf den Registry-Wert angezeigt

[Nur Leserechte] (in der Farbe ROT)

Das bedeutet, Sie dürfen die Registry-Werte zwar lesen, jedoch nicht verändern.

Dies ist der Fall, wenn Sie als (Haupt-)Benutzer unter NT/2000/XP/2003 angemeldet sind und Werte außerhalb von HKEY_CURRENT_USER ändern wollen.

[Schreibrechte] (in der Farbe Blau)

Das bedeutet, Sie dürfen die Registry-Werte lesen und auch ändern.

Das ist meist der Fall, als (Haupt-)Benutzer unter NT/2000/XP/2003 unter HKEY_CURRENT_USER oder wenn Sie als Administrator angemeldet sind, in der kompletten Registry.


Die Buttons unter: Registry Schlüssel

Hier können Sie je nach Auswahl und Einstellung folgende Buttons sehen:

Speichern:

Mit diesem Button speichern Sie die Veränderungen in der Registry ab.

Löschen:

Dieser Button ist nur freigeschaltet, wenn Sie ihn unter "Extras" -> "Optionen" -> "Allgemein" aktiviert haben.

Mit diesem Button können Sie Registrywerte aus der Registry löschen. Sie sollten damit aber sehr vorsichtig sein und nur Werte löschen, die wirklich nicht gebraucht werden. Aus diesem Grunde ist dieser Button standardmäßig deaktiviert.

KeyInfo:

Hier wird Ihnen angezeigt, auf welche Registrywerte in der Registry zugegriffen wird und wo sie in der Registry zu finden sind.

Standard:

Wenn es für diesen Wert einen Standardwert gibt, sehen Sie auch diesen Button. Durch einen Klick auf diesen Button können Sie die Windows Standardeinstellung dieses Tipps wiederherstellen.


Registry durchsuchen

Über Extras, Registry durchsuchen... gelangen Sie zu einem umfangreichen und mächtigen Tool um die Registry zu durchsuchen, Werte zu löschen und zu exportieren.

Im Hauptfenster geben Sie unter Suchtext den gewünschten Wert ein und klicken auf Start

Im Beispiel die Suche nach RSW.EXE.

Mit einem Doppelklick auf ein Ergebnis bekommen Sie nach dem sorgfältigen Lesen dieses Sicherheitshinweises:

detaillierte Informationen zu dem gefundenen Schlüssel.

Selbstverständlich stehen Ihnen auch beim Registry duchsuchen wieder die Netzwerkfunktionen des Registry System Wizards zur Verfügung. (siehe auch Registry übers Netzwerk bearbeiten)

Die Funktionen von Registry durchsuchen im Einzelnen:

Das Menü Datei:

Dieses benötigen Sie nur um die Suche zu schließen.

Das Menü Bearbeiten:

Mit Markierte Keys exportieren werden alle mit einem Häkchen versehenen Schlüssel in eine Datei exportiert.

Es erscheint eine Dialogbox, in der Sie den Namen und den Speicherort der REG-Datei angeben müssen.

Mit Markierte Keys löschen werden alle mit einem Häkchen versehenen Schlüssel gelöscht

Vor dem Löschen erscheint noch eine Sicherheitswarnung, die Sie darüber informiert, was das bedeutet.

Alle auswählen, markiert alle gefundenen Schlüssel.

Alle abwählen, demarkiert alle gefundenen Schlüssel.

Das Menü Suchen

Start startet die Suche.

Stop bricht die Suche ab.

Das Menü Optionen

Im Menü Optionen legen Sie die Suchkriterien fest

Schlüsselname sucht nur nach Schlüsselnamen

Wertname sucht nur nach Wertname

Wert sucht nur nach Werten

Genauer Wortlaut findet nur genau das Suchwort

Unter Unicode einbeziehen können Sie die Umwandlung von ASCII-Zeichen in Unicode-Zeichen deaktivieren.

Was ist Unicode?

Suchausgabe aktiviert, zeigt während des Suchvorgangs die gerade durchsuchte Stelle der Registry in der Statuszeile an


Sichern und Wiederherstellen der Registry

Wenn man Änderungen an der Registry durchführt, sollte man normalerweise die Registry sichern, um sie im Fehlerfall wiederherstellen zu können.

Im RSW gibt es eine Funktion, womit Sie die Registry sichern können. Hier finden Sie eine ausführliche Beschreibung, wie die Registry gesichert wird.

Sichern der Registry (Backup)

Info:

Damit Sie die ganze Registry sichern können, müssen Sie unter Windows NT/2000/XP/2003 über administrative Rechte verfügen!

Im RSW gelangen Sie über das Menü "Datei" -> "Registry Sichern/Herstellen" in das Ansichtsfenster "Registry Sichern und Wiederherstellen"

Hier sehen Sie alle Sicherungen, die auf Ihrem Rechner vorhanden sind (natürlich nur, wenn Sie bereits Sicherungen erstellt haben).

Über den Button "Sichern" können Sie eine neue Sicherung der Registry anlegen. Wenn Sie auf den Button "Sichern" klicken, werden Sie gebeten, einen beliebigen Text für die Beschreibung der Sicherung einzugeben.

Sie bekommen noch einen Hinweis, dass das System während dieser Sicherung sehr träge sein wird.

Danach wird die Registry gesichert.

Mit einem Hinweisfenster wird Ihnen mitgeteilt, ob die Sicherung erstellt werden konnte.

Die Sicherungsdateien werden in dem Unterordner Backup vom Registry System Wizard gespeichert.

Die Ordnerstruktur schaut folgendermaßen aus:

Registry System Wizard\Backup\Computername\Benutzername\Betriebssystem\Datum-und-Uhrzeit

Also z. B:

Registry System Wizard\Backup\MeinPC\admin\Windows XP 5.1.2600\2004-08-19_14-43-08

Wiederherstellen der Registry (Restore)

Achtung!

Beim Wiederherstellen der Registry werden alle vorhandenen Einträge mit der gesicherten Registry überschrieben und der alte Zustand wieder hergestellt. Sollten Sie zwischenzeitlich Software installiert haben, die Einträge in der Registry vorgenommen hat, werden diese Änderungen rückgängig gemacht. Dies kann dazu führen, dass diese Programme nicht mehr funktionieren werden.

Wählen Sie im Ansichtsfenster "Registry Sichern und Wiederherstellen" aus der Liste der vorhandenen Sicherungen die Sicherung aus, die Sie wiederherstellen wollen und klicken Sie auf den Button "Herstellen".

Je nach Betriebssystem geht es nun unterschiedlich weiter:

Windows NT/2000/XP/2003

Hier erscheint nun ein Fenster mit der Übersicht, welches Backup ausgewählt wurde. Weiterhin können Sie hier einzelne Registryschlüssel vom Zurückschreiben ausschließen.

Standardmäßig sind alle Registryschlüssel ausgewählt. Durch den Klick auf "Herstellen" wird das Zurückschreiben der Registry gestartet, danach muss unbedingt ein Neustart des Systems durchgeführt werden, damit das System die Änderung mitbekommt.

Nach den Neustart des Systems finden Sie folgende Dateien im Rootverzeichnis Ihres Systemlaufwerkes:

Dateiname | Beschreibung
RSW_HKLM_System.bin.up | Sicherung von HKLM\SYSTEM
RSW_HKLM_Software.bin.up | Sicherung von HKLM\Software
RSW_HKLM_Hardware.bin | Sicherung von HKLM\Hardware
RSW_HKLM_Security.bin.up | Sicherung von HKLM\Security
RSW_HKLM_SAM.bin.up | Sicherung von HKLM\Sam
RSW_HKU_xxx.bin.up | Sicherungsdaten des aktuellen USERS (xxx steht für die UID des jeweiligen USERS)
RSW_HKU_xxx_Classes.bin.up | Sicherungsdaten des aktuellen USERS (xxx steht für die UID des jeweiligen USERS). Nur bei Windows 2000 vorhanden
RSW_HKCU_Default.bin.up | Sicherung des Deafult-User Profil
RSW_HKU_xxx_CLASSES.bin.LOG | Log-Datei für das Zurückschreiben (xxx steht für die UID des jeweiligen USERS)
RSW_HKU_xxx.bin.LOG | Log-Datei für das Zurückschreiben (xxx steht für die UID des jeweiligen USERS)
RSW_HKCU_Default.bin.LOG | Log-Datei für das Zurückschreiben
RSW_HKLM_System.bin.LOG | Log-Datei für das Zurückschreiben
RSW_HKLM_Software.bin.LOG | Log-Datei für das Zurückschreiben
RSW_HKLM_Security.bin.LOG | Log-Datei für das Zurückschreiben
RSW_HKLM_SAM.bin.LOG | Log-Datei für das Zurückschreiben

Alle Dateien mit der Dateiendung ".up" enthalten die Sicherung der Registry vor dem Zurückschreiben und werden automatisch aus Sicherheitsgründen angelegt. Wenn das System fehlerfrei arbeitet, können Sie diese Dateien bedenkenlos löschen. Die Dateien mit der ".log" Endung können sofort gelöscht werden.

Info: Der RSW löscht diese Dateien nicht von alleine. Wenn Sie aber wieder eine Sicherung herstellen und dieses Dateien immer noch vorhanden sind, werden sie automatisch mit den neuen Sicherungsdateien überschrieben.

Windows 9x/ME

Windows 9x/ME bietet leider keine so gute Funktion zum Herstellen der Registry wie Windows NT/2000/XP/2003, auch kann hier immer nur die gesamte Registry zurückgeschrieben werden.

Wenn Sie hier auf den Button "Herstellen" klicken, wird das ausgewählte Backup in das Windows Systemverzeichnis kopiert und es wird im Rootverzeichnis eine Batchdatei mit dem Namen "Restor.bat" angelegt. Um die Registry zurückzuschreiben, müssen Sie das System im DOS-Modus starten und die Batch-Datei ausführen.

Windows 9x können Sie ja noch leicht im MS-DOS Modus starten, für Windows ME benötigen Sie eine DOS-Startdiskette.

Info: Nur im MS-DOS Modus können Sie die Registry zurückschreiben. Ein Starten der RESTOR.BAT unter Windows führt zu einem Fehler!

Windows startet nicht mehr

Registry wieder herstellen, wenn Windows nicht mehr startet:

Mit dem RSW können Sie eine Sicherung der Registry erstellen. Wenn aber Windows aufgrund eines Fehlers in der Registry nicht mal mehr im abgesicherten Modus startet, hilft Ihnen auch das Backup des RSW nicht mehr weiter.

Wenn Sie Glück haben, können Sie über folgenden Weg trotzdem noch die Registry über den RSW wieder zurückspielen:

  • Starten Sie Windows über die SETUP-CD und drücken Sie auf der Willkommensseite die Taste R (Wiederherstellungskonsole).

  • Melden Sie sich über 1 an Ihrem defekten Windows-System an. Sie werden bei der Anmeldung nach Ihrem Administratorpasswort gefragt.

  • Geben Sie nun die folgenden Befehle ein (überschreiben der Dateien jeweils mit J bestätigen):

    • copy c:\windows\repair\software c:\windows\system32\config\software

    copy c:\windows\repair\system c:\windows\system32\config\system

    copy c:\windows\repair\security c:\windows\system32\config\security

    copy c:\windows\repair\default c:\windows\system32\config\default

    copy c:\windows\repair\sam c:\windows\system32\config\sam

    Wenn Sie Windows in einem anderen Verzeichnis installiert haben, müssen Sie die Pfade entsprechend anpassen.

  • Beenden Sie jetzt die Wiederherstellungskonsole und starten Sie Windows jetzt wieder über die Festplatte neu.

  • Beim Starten gehen Sie über F8 in den abgesicherten Modus.

  • Starten Sie die RSW.EXE über /nodb. Das bewirkt, dass keine Tippdatenbank beim Laden geöffnet wird und somit kein MDAC benötigt wird. Sie können die Registry aber wieder zurückschreiben.

  • Wählen Sie nun unter Backup/Restore die gewünschte Sicherung der Backups aus und starten Sie anschließend den Rechner neu.


Der Verlauf

Den Verlauf rufen Sie mit einem Klick auf Verlauf in der Symbolleiste bzw. über Bearbeiten | Verlauf der Änderungen auf. Es öffnet sich das folgende Fenster:

Unter Datum sehen Sie alle Änderungen nach Datum sortiert.

Unter Key werden die Änderungen nach Änderungsart aufgelistet:

  • ob es eine Änderung unter HKCU ist

  • ob es eine Änderung unter HKLM ist

  • ob es eine Änderung in einer INI-Datei ist

Unter ABC werden die Änderungen in alphabetischer Reihenfolge angezeigt.

Durch markieren eines Schlüssels bekommen Sie alle Details (auch das Änderungsdatum und Uhrzeit durch den RSW), die diesen Schlüssel betreffen, angezeigt:

Um die History zu exportieren, gehen Sie folgendermaßen vor:

Starten Sie das Verlaufs-Fenster wie oben abgebildet und wählen Sie die Anzeige aus (Datum, Key oder ABC).

Dann wählen Sie alle Schlüssel aus, die Sie exportieren wollen. Nun müssen Sie noch entscheiden, welche Werte exportiert werden sollen.

Hierbei haben Sie folgende Auswahlmöglichkeiten:

  • Sie exportieren den Wert, der vor der Änderung mit dem RSW in der Registry stand.

  • Sie exportieren den Wert, der aktuell in der Registry steht.

  • Sie exportieren den Wert, den Sie mit dem RSW eingestellt haben. Dieser Wert ist im Normalfall mit dem aktuell in der Registry befindlichen Wert. Wenn Sie jedoch nach der Änderung mit dem RSW manuell oder mit einem anderen Registry-Tweaker Veränderungen an der Registry vorgenommen haben, dann können diese Werte auch unterschiedlich sein.

Die Auswahl, welchen Wert Sie exportieren wollen, erreichen Sie über einen Klick auf Optionen.

Weitere Optionen des Verlaufs sind:

Sie können über Bearbeiten | Aktuellen Eintrag löschen bzw. Bearbeiten | Alle markierten Einträge löschen Einträge aus dem Verlauf entfernen.

Sie können über Wiederherstellen | Aktuellen Eintrag wiederherstellen bzw. Wiederherstellen | Alle markierten Einträge wiederherstellen Einträge die Sie mit dem RSW durchgeführt haben wieder in den Zustand vor der Änderung durch den RSW zurücksetzen.

Bedenken Sie, dass Änderungen, die Sie manuell oder mit einem anderen Registry-Tweaker durchgeführt haben, nicht berücksichtigt werden.

Sie können über REG-File | Aktuellen Eintrag als REG-File speichern bzw. REG-File | Alle markierten Einträge als REG-File speichern, die ausgewählten Einträge des Verlaufs als REG-Datei speichern um diese Änderungen z. B. auf einem anderen PC durchzuführen.

Über Optionen gelangen Sie zu den Verlaufs-Optionen.

Wenn Sie den RSW neu installieren oder die Verlaufs-Datei auf einen anderen PC übertragen wollen, dann müssen Sie im RSW-Installationsverzeichnis die Datei RSWDaten History.xml sichern.

Anders herum, brauchen Sie auch lediglich diese Datei zu löschen um den kompletten Verlauf zurückzusetzen.


Registry übers Netzwerk bearbeiten

Sie können den Registry System Wizard auch dazu verwenden, die Registry von entfernten Rechnern in Ihrer Arbeitsgruppe oder Ihrer Domäne zu bearbeiten.

Starten Sie hierzu den Registry System Wizard und wählen Datei Registry über Netzwerk bearbeiten aus.

Folgender Dialog öffnet sich:

Unter Domain/Workgroup geben Sie den Namen Ihrer Arbeitsgruppe bzw. Ihrer Domäne ein.

Mit einem Klick auf Refresh können Sie sich alle verfügbaren Rechner anzeigen lassen.

Anmerkung:

Wenn Sie auf einigen Rechnern den Registry-Eintrag Rechner im Netzwerk nicht anzeigen gesetzt haben, dann werden diese Rechner hier natürlich auch nicht angezeigt).

Sollte Ihr Wunsch-PC nicht in der Liste auftauchen,geben Sie den Namen (oder die IP-Adresse) einfach hinter Lokaler PC >> ein.

Unter Anmelden als >> können Sie noch die Anmeldeinformationen für das Zielsystem angeben. In einer Domäne sind Sie wahrscheinlich Domänenadmin und Sie können einfach auf OK klicken.

In einer Arbeitsgruppe oder wenn Ihr Unternehmen über mehrere Domänen verfügt, geben Sie einfach nach einem Klick auf Anmelden als >> im folgenden Dialogfeld den Benutzernamen und das Passwort ein.

Per Klick auf das Kopf-Symbol bekommen Sie im Idealfall einen Auswahldialog zu sehen (dieses kann bei langsamen oder auch größeren Netzwerken eine Weile dauen), in welchem Sie einfach den passenden Benutzer, der die nötigen Rechte besitzt, auswählen.


ADM-Tipp Liste speichern

Hier finden werden alle von Ihnen zur ADM-Tippliste hinzugefügten Tipps aufgeführt:

Die Liste wird in zwei Bereiche aufgeteilt:

- HKCU (HKEY_CURRENT_USER)
Enthält alle Tipps, die in den Bereich „Class USER“ der ADM-Datei geschrieben werden. Mit diesen Tipps werden die Einstellungen der USER festgelegt.

- HKLM (HKEY_LOCAL_MACHINE)
Enthält alle Tipps, die in den Bereich „Class MACHINE“ der ADM-Datei geschrieben werden. Mit diesen Tipps werden die Einstellungen einer Maschine gesteuert. Diese Einstellungen gelten für alle Personen, die sich an diesen Rechner anmelden.

Die Tipps werden in der Liste sortiert angezeigt. In der ersten Spalte steht der Name des Tipps, in der zweiten Spalte (Policy) wird angezeigt, ob es sich um einen Policy Tipp handelt.

Mit Policy sind alle Tipps gemeint, wodurch Werte in der Registry unterhalb von "Policies Schlüsseln" verändert werden (z.B.: URRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies). Diese Schlüssel werden in der MMC "Gruppenrichtlinien" auch immer angezeigt.

Wenn Sie auch andere Schlüssel zur Policy hinzufügen, werden die in der MMC "Gruppenrichtlinien" erst angezeigt, wenn Sie die Option " Nur vollständig verwaltbare Richtlinieneinstellungen anzeigen " deaktivieren.

Die Buttons:

Speichern: | Erstellt das ADM-File mit den oben eingetragenen Tipps
Zurück: | Geht wieder zum RSW Hauptprogramm zurück
Eintrag löschen: | Löscht die markierten Einträge
Alles löschen: | Löscht alle Einträge
Hilfe: | Zeigt diese Hilfe


Eigene Tipps über den Wizard hinzufügen

Sie können mit der aktuellen Version vom "Registry System Wizard" auch eigene Datenbanken laden und sich so eine private Tippsammlung aufbauen. Dafür gibt es einen Wizard, der Ihnen beim hinzufügen von neuen Einträge behilflich ist.

Info: Das ist die erste Version dieses Wizard. Es ist also noch nicht alles möglich was der RSW selber kann. Diese Funktion wurde deshalb jetzt schon freigegeben, um entsprechende Informationen vom Anwender zu bekommen, was man verändern sollte bzw. was noch gewünscht wird.

Über entspechende Hinweise im Forum (http://www.equipmente.de ) bzw. über E-Mail würden wir uns freuen.

Wenn Sie einen Eintrag hinzufügen wollen, gehen Sie folgendermaßen vor:

Starten Sie über das Menü „Extras“ -> „RSW Registry Browser“ den im RSW eingebauten Registry-Browser.

Gehen Sie hier im Baum zum gewünschten Eintrag und klicken Sie auf den gewünschten Wert. Über das Menü „Optionen“ -> „Wert in DB Speichern“ können Sie den Wizard starten der Ihnen dabei behilflich ist diesen Wert in der Datenbank abzulegen:

Der Wizard

Als erstes wird Ihnen eine mögliche Datenbank für das Speichern des Tipps angeboten. Wenn Sie schon Ihre eigene Tippdatenbank geladen haben, wird diese zum Speichern des neuen Tpps vorgeschlagen.

Wenn noch die RSW-Datenbank geladen ist, wird eine neue Datenbank mit dem namen des Windows-Account vorgeschlagen. Sie können hier aber jederzeit eine andere Datenbank auswählen.

Wenn die Datei OK ist, klicken Sie einfach auf den Button "Weiter >".

Im nächsten Tabreiter "Registrywert" werden Ihnen die Daten für den ausgewählten Wert aus der Registry angezeigt (die Werte können hier nicht geändert werden). Sie können hier nur über "HKCU und HKLM möglich" festlegen, ob es sich um einen Policy-Key handelt, der unter beiden Rootschlüsseln angelegt werden kann.

Wenn die Daten soweit OK sind, klicken Sie auf den Button "Weiter >".

Als nächsten müssen Sie die allgemeinen Informationen zum Tipp eingeben, diese Informationen können nicht aus der Registry gelese werden, weshalb Sie hier alles selber ausfüllen müssen.

Überschrift: Legt die Überschrift für den neuen Tipp im RSW fest

Beschreibung: Legt die Beschreibung für den Tipp fest, diese Beschreibung wird oben im RSW bei jedem Tipp angezeigt.

Betreibssystem: Legt fest für welches Betriebssystem der Tipp gültig ist. Es wird automatisch das Betriebssystem ausgewählt, welches gerade gestartet ist.

Wenn die Daten soweit OK sind, klicken Sie auf den Button "Weiter >".

Als nächtes geben Sie die entsprechenden Gruppen an, unter welchen der Tipp im RSW angezeigt werden soll.

Sie können zurzeit noch keine eigenen Tippgruppen erstellen.

Wenn die Daten soweit OK sind, klicken Sie auf den Button "Weiter >".

Unter den Tabreiter "Wert" können Sie bestimmen wie die Eingabe im RSW aussehen soll. Anhand des Datentypes und des aktuellen Inhaltes versucht der Wizard selber eine entsprechende Möglichkeit zu finden.

Es gibt bis jetzt nur 3 Auswahlmöglichkeiten:

Aus/Einschalten (Boolean):

Weiterhin kann hier auch noch "[RSW:DELWORD]" bzw. "[RSW:DELKEY]" eingetragen werden. Wenn Sie das z.B. bei Deaktiv eintragen, wird der Eintrag aus der Registry gelöscht, wenn der Tipp deaktiviert wird.

"[RSW:DELWORD]" -> Nur der Wert wird gelöscht

"[RSW:DELKEY]" -> Der ganze Key wird gelöscht (inklusive aller Unterschlüssel). Mir diesen Eintrag sollten Sie also sehr vorsichtig umgehen!

Textwert:

Hier kann man später im Wizard einen beliebigen Text eingeben. Bei "Standard Wert" ist hier auch noch der Wert "[RSW:DELKEY]" möglich, fals der Eintrag über diesen Button aus der Registry gelöscht werden soll.

"[RSW:DELWORD]" -> Nur der Wert wird gelöscht

"[RSW:DELKEY]" -> Der ganze Key wird gelöscht (inklusive aller Unterschlüssel). Mir diesen Eintrag sollten Sie also sehr vorsichtig umgehen!

Zahlenwerte:

Hier können Zahlenbereiche festgelet werden.Bei "Min Wert" und "Max Wert" dürfen nur Zaheln eingegeben werden. Bei "Standard Wert" ist hier auch noch der Wert "[RSW:DELKEY]" möglich, fals der Eintrag über diesen Button aus der Registry gelöscht werden soll.

"[RSW:DELWORD]" -> Nur der Wert wird gelöscht

"[RSW:DELKEY]" -> Der ganze Key wird gelöscht (inklusive aller Unterschlüssel). Mir diesen Eintrag sollten Sie also sehr vorsichtig umgehen!

Info: Weitere vom RSW bekannte Auswahlmöglichkeiten werden noch folgen.

Wenn die Daten soweit OK sind, klicken Sie auf den Button "Save". Der neue Tipp wird anschließend in der entsprechenden Datenbank gespeichert.

Anschließend können Sie die Datenbank über das Menü Datei öffnen.


Aufbau der Datenbank

Neue Einträge können nur in Ihre eigene Datenbank hinzugefügt werden. Standardmäßig wird eine Datenbank erstellt, die nach Ihren Anmeldenamen benannt wird, Sie können das aber beliebig ändern.

Im Verzeichnis vom Registry System Wizard finden Sie folgende Dateien:

RSWDaten.mdb | Das ist die Original Datenbenk vom Registry System Wizard. Diese Datenbank kann nicht bearbeitet werden, da sie ausschließlich vom Team der WinFAQ zu Verfügung gestellt wird.
Beispiel.mdb | Das ist eine kleine Datenbank die schon mit einigen Daten gefüllt ist um Ihnen zu zeigen wie die Daten in der Datenbank ausssehen.
leer.mdb | Das ist eine leere Datenbank, die Sie als Vorlage benutzen können. Kopieren Sie einfach diese Datei und geben Sie ihr einen beliebigen Namen.

Hier finden Sie eine kurze Beschreibung der vorhandenen Tabellen und Ihrer Bedeutung

Die ASW_* Tabellen (Diese Tabellen dienen nur zur Vereinfachung der Eingabe über die Formulare):

ASW_Datentypen

ASW_Eingabearten

ASW_Icon

ASW_Rootkey

Die restlichen Tabellen:

GroupName | Enthält die Namen der Gruppen mit der entsprechenden Beschreibung. Jeder Tipp wird kann so einer Gruppe zugeordnet werden.
GroupTree | Beschreibt den Aufbau der Gruppen als Tree. Angefangen wird immer mit dem ersten Eintrag. Danach wird über NextTreeID der nächste Eintrag im Tree festgelegt. GroupID_fk bestimmt die Gruppe die angezeigt wird und Order die Tiefe: Order 0 -> Oberste Treebene Order 1 -> Eintrag wird unter dem Vorgänger angezeigt usw.
RSWDBInfo | Gibt die Info über den Stand der Datenbank an. Diesen Wert bitte nicht verändern, da damit der Registry System Wizard erkennen kann, ob er mit dieser Datenbank (Tabellen, Spalten usw.) umgehen kann.
Tip | Enthält die Grunddaten für die Tipps.
TipINIData | Enthält die Daten für Tipps, die auf INI-Dateien zugreifen.
TipRegData | Enthält die Daten, die Tipps in die Registry schreiben.
Version | Enthält nur die Versionsnummer für die einzelnen Tipps.

Die Eingabe der Tipps erfolgt über die Formulare "Eingabe Registry-Tipps" bzw. "Eingabe INI-Tipps"


Tabelle: Tip

Die Tabelle Tip. Hier werden die Grundinformationen zu einem Tipp gespeichert. Sie sollten zur Eingabe der Tipps das Formular "Eingabe -Registry Tipps" oder "Eingabe -INI-Tipps" verwenden.

Name | Datentyp | Pflichfeld | Beschreibung | Erlaubte Zeichen | Aus Tabelle
Tip_ID | Long Integer | Ja | Eindeutige ID des Tipps, wird automatisch erzeugt | [0-9] |
GroupID_fk | Text [50] | Ja | Gruppenzuordnung im Tree. Bei mehr als 1 Gruppenzugehörigkeit müssen die Gruppen durch # getrennt werden | [0-9,#] | GroupName
Header | Text [150] | Ja | Enthält die Überschrift für den Tipp | ASCII - Zeichen |
Description | Memo | Nein | Enthält eine Beschreibung für den Tipp | ASCII - Zeichen |
ContextNumber | Integer | Ja | Enthält die Nummer für weitere Informationen aus der WinFAQ Hilfe Datei. Ist keine weitere Hilfe verfügbar 9999 | [0-9] |
ValueTypCeck | Boolean | Ja | Gibt an, ob bei Unterschied zwischen dem Datentyp der Datenbank und der Registry eine Warnmeldung ausgeben werden soll | [0,1] |
Icon | Byte | Ja | Nummer für das Icon, welches angezeigt werden soll | [0 bis 38 | ASW_Icon
BS_95 | Boolean | Ja | Tipp ist für Windows 95 geeignet | [0,1] |
BS_98 | Boolean | Ja | Tipp ist für Windows 98 geeignet | [0,1] |
BS_ME | Boolean | Ja | Tipp ist für Windows ME geeignet | [0,1] |
BS_NT | Boolean | Ja | Tipp ist für Windows NT geeignet | [0,1] |
BS_2000 | Boolean | Ja | Tipp ist für Windows 2000 geeignet | [0,1] |
Version | Text [50] | Nein | Versionsnummer der Datenbank, seit der Tipp in der DB vorhanden ist | ASCII - Zeichen | Version
Reboot | Byte | Ja | 0 = no reboot, 1= reboot, 2 = logoff | [0,1,2] |
BS_XP | Boolean | Ja | Tipp ist für Windows XP geeignet | [0,1] |
ADM | Boolean | Ja | Vom Tipp kann ein ADM-File erstellt werden | [0,1] |
INI | Boolean | Ja | Tipp bezieht sich auf eine INI-Datei | [0,1] |


Tabelle: TipRegData

Die Tabelle TipRegData. Hier werden die speziellen Infos zu einem Tipp gespeichert. Sie sollten zur Eingabe der Tipps das Formular "Eingabe -Registry Tipps" verwenden.

Name | Datentyp | Pflichfeld | Beschreibung | Erlaubte Zeichen | Aus Tabelle
TipRegData_ID | Long Integer | Ja | Eindeutige ID des Tipps, wird automatisch erzeugt | [0-9] |
TipID_fk | Long Integer | Ja | Verweis zum Mutter-Tipp | [0-9] | Tip
RootKey_1 | Text [4] | Ja | Hauptschlüsselname (erster Standardschlüssel, Pflicht) | [HKCU, HKLM, HKU, HKDD, HKCC, HKCR] | ASW_Rootkey
RootKey_2 | Text [4] | Nein | Hauptschlüsselname (zweiter Schlüssel, falls Key unter User und Maschine gesetzt werden kann) | [HKCU, HKLM, HKU, HKDD, HKCC, HKCR] | ASW_Rootkey
KeyPfad | Text [255] | Ja | Schlüsselpfad | Ascii-Zeichen |
ValueName | Text [40] | Nein | Wertname des zu ändernden Schlüssels. Beim Wert (Standard) wird hier nichts eingegeben | Ascii-Zeichen |
ValueTyp | Zahl | Ja | Datentyp des Schlüssels (mögliche Wert: 1,2,3,4,7) | [1,2,3,4,7] | ASW_Datentypen
InputTyp | Zahl | Ja | Legt die Eingabart für den Anwender fest und bestimmt so mögliche Werte und wie der Tipp im Registry System Wizard angezeigt wird | [1,2,3,4,5,6,7,8,10,11] | ASW_Eingabearten
Show_ValueName | Text [20] | Nein | Legt den Text fest, der bei diesem Tipp statt des ValueName erscheinen soll. Ist der Wert leer, wird der ValueName angezeigt | Ascii-Zeichen |
Max | Text [100] | Nein | siehe Tabelle Eingabeart MinMax | Je nach Datentyp und [RSW:delkey] |
Min | Text [100] | Nein | siehe Tabelle Eingabeart MinMax | Je nach Datentyp und [RSW:delkey] |
Default | Text [100] | Nein | Legt fest was gemacht werden soll, wenn der User auf den Button Standard drückt | Je nach Datentyp und [RSW:delkey] |
Show_Entry | Memo | Nein | siehe Tabelle Eingabeart Entry |  |
Registry_Entry | Memo | Nein | siehe Tabelle Eingabeart Entry |  |

Tabelle: Eingabeart Entry

InputTyp | Show_Entry | Registry_Entry
Boolean (1) | Text hinter dem Boolean Eintrag (Beschreibt den Zustand, wenn Haken gesetzt). Beispiel [aktiviert] | keine Funktion
Texteingabe (2) | keine Funktion | keine Funktion
Zahlenwerte (3) | Gibt die Einheit als Info an (in Sekunden, in Minuten, kByte, Wert) |
Auswahlbox (4) | Einträge, die bei Auswahl in die Registry geschrieben werden sollen. Die Einträge sind durch # zu trennen | Gibt den Wert an, der eingetragen werden soll, wenn der Gegenwert unter Zusatz ausgewählt wird. Die Einträge sind durch # zu trennen
Auswahlmöglichkeiten (5) | Bezeichnung für die Auswahlmöglichkeiten. Die Einträge sind durch # zu trennen | Gibt den Wert an, der eingetragen werden soll, wenn der Gegenwert unter Zusatz ausgewählt wird. Die Einträge sind durch # zu trennen
Datei/Verzeichnisauswahl (6) | Beschreibung für die Auswahlmöglichkeiten | Filter für die anzuzeigenden Dateien ( *.*, *.wav, *.bmp)
Farbauswahl (7) | Bezeichnung für die Auswahl | keine Funktion
Auswahlbox (8) | Beschreibung für die Einträge. Die Einträge sind durch # zu trennen | Gibt den Wert an, der eingetragen werden soll, wenn der Gegenwert unter Zusatz ausgewählt wird. Die Einträge sind durch # zu trennen
ContextMenü (10) | keine Funktion | keine Funktion
BIT-Maskiert (11) | Gibt die Beschreibung für die einzelnen Bytes vor. Die Einträge sind durch # zu trennen | keine Funktion

Tabelle: Eingabeart MinMax

InputTyp | Min | Max
Boolean (1) | Legt den Wert fest, der gespeichert wird, wenn der Tipp nicht aktiviert ist. Der Eintrag [RSW:delkey] löscht den Registry Wert bei Nichtaktivierung. | Legt den Wert fest der gespeichert wird wenn der Tipp aktiviert ist. Der Eintrag [RSW:delkey] löscht den Registry Wert bei Aktivierung.
Texteingabe (2) | keine Funktion | keine Funktion
Zahlenwerte (3) | Minimaler Wert | Maximaler Wert
Auswahlbox (4) | keine Funktion | keine Funktion
Auswahlmöglichkeiten (5) | keine Funktion | keine Funktion
Datei/Verzeichnisauswahl (6) | keine Funktion | keine Funktion
Farbauswahl (7) | keine Funktion | keine Funktion
Auswahlbox (8) | Wert, wenn Eintrag nicht aktiviert. Der Eintrag [RSW:delkey] löscht den Registry Wert bei Nichtaktivierung. | Wert wenn Eintrag aktiviert. Der Eintrag [RSW:delkey] löscht den Registry Wert bei Aktivierung.
ContextMenü (10) | keine Funktion | keine Funktion
BIT-Maskiert (11) | keine Funktion | keine Funktion

Folgende Variablen können benutzt werden (Groß/Kleinschreibung beachten):
[RSW:WindowsPfad] | Wird durch den Pfad ersetzt
[RSW:delkey] | Löscht den Eintrag


Tabelle: TipINIData

Die Tabelle TipINIData. Hier werden die speziellen Infos zu einem Tipp gespeichert. Sie sollten zur Eingabe der Tipps das Formular "Eingabe -INI Tipps" verwenden.

Name | Datentyp | Pflichfeld | Beschreibung | Erlaubte Zeichen | Aus Tabelle
TipINIData_ID | Long Integer | Ja | Eindeutige ID des Tipps, wird automatisch erzeugt | [0-9] |
TipID_fk | Long Integer | Ja | Verweis zum Mutter-Tipp | [0-9] | Tip
SektionName | Text [255] | Ja | Sektion Name aus der INI-Datei | Ascii-Zeichen |
FileName | Text [255] | Ja | Dateiname der INI-Datei | Ascii-Zeichen |
Wertname | Text [40] | Nein | Name der eingetragen/verändert werden soll | Ascii-Zeichen |
InputTyp | Zahl | Ja | Legt die Eingabeart für den Anwender fest und bestimmt so mögliche Werte und wie der Tipp im RSW angezeigt wird | [1,2,3,4,5,6,7,8,10,11] | ASW_Eingabearten
Show_WertName | Text [20] | Nein | Legt den Text fest, der bei diesem Tipp statt des WertName erscheinen soll. Ist der Wert leer, wird der WertName angezeigt | Ascii-Zeichen |
Max | Text [100] | Nein | siehe Tabelle Eingabeart MinMax |  |
Min | Text [100] | Nein | siehe Tabelle Eingabeart MinMax |  |
Default | Text [100] | Nein | Legt fest was gemacht werden soll wenn der User auf den Button Standard drückt |  |
Zusatz | Memo | Nein | siehe Tabelle Eingabeart WertName |  |
Pfad | Text [255] | Ja | Pfad zur INI-Datei |  |

Tabelle: Eingabeart WertName

InputTyp | Show_WertName
Boolean (1) | keine Funktion
Texteingabe (2) |
Zahlenwerte (3) | Gibt die Einheit als Info an (in Sekunden, in Minuten, kByte, Wert)
Auswahlmöglichkeiten (5) | Bezeichnung für die Auswahlmöglichkeiten. Die Einträge sind durch # zu trennen
Boot.INI (9) | Gibt die Einträge in der Boot.INI durch # getrennt an

Tabelle: Eingabeart MinMax

InputTyp | Min | Max
Boolean (1) | Legt den Wert fest, der gespeichert wird, wenn der Tipp nicht aktiviert ist. | Legt den Wert fest, der gespeichert wird, wenn der Tipp aktiviert ist.
Texteingabe (2) | keine Funktion | keine Funktion
Zahlenwerte (3) | Minimaler Wert | Maximaler Wert
Auswahlmöglichkeiten (5) | keine Funktion | keine Funktion
Boot.INI (9) | keine Funktion | keine Funktion

Folgende Variablen in der Spalte "Pfad" werden benutzt (Groß/Kleinschreibung beachten):
%SYSTEMDRIVE% | Wird durch das Windows-Laufwerk ersetzt.
%SYSTEMROOT% | Wird durch das Windows-Verzeichnis ersetzt.


ADM Dateien

Mit dem RSW können Sie aus den meisten Tipps eine ADM-Vorlage (Template) erstellen. Sie können entweder einen einzelnen Tipp oder aber eine beliebe Anzahl Tipps zusammenstellen und anschließend als .adm Datei speichern.

Diese ADM-Vorlage dient unter Windows als Grundlage um entsprechende Einstellungen vornehmen zu können, welche in der Datei .pol abgespeichert werden. Eine ADM-Datei zeigt also Quasi nur eine Maske für die möglichen Einstellungen an und die gewünschten Konfigurationen vornehmen zu können.

Werden entsprechende ADM-Dateien (Vorlagen) wieder entfernt, bleiben die durchgeführten Konfigurationen in der .pol Datei erhalten, werden aber in der Oberfläche zur Konfiguration nicht mehr angezeigt. Vor den löschen von ADM-Dateien sollte Sie deshalb die durchgeführten Konfigurationen wieder rückgängig machen.

Der Gruppenrichtlinieneditor bzw. Poledit lädt also die entsprechenden Vorlagen und wertet anschließend anhand der Vorlagendatei die .pol Datei aus. Datei werden nur die Einträge berücksichtigt, die entsprechend über die ADM-Dateien bekannt sind alle anderen Einträge werden nicht angezeigt.


Wie kann ich die ADM-Dateien benutzen?

Die erstellen ADM-Dateien können Sie anschließend unter Windows laden und damit Einstellungen recht einfach setzen. Gehen Sie dafür folgendermaßen vor:

Windows 9x/ME und NT

Hier benötigen Sie das Programm „POLEDIT.EXE“ von MS. Mit diesem Programm können Sie die ADM-Dateien laden. Dafür starten Sie das Programm und klicken eventuelle Fehlermeldungen einfach weg (wenn Sie noch kein ADM-File geladen haben, sucht das Programm automatisch nach COMMAND.ADM). Brechen Sie diese Suche so lange ab, bis das Programm gestartet ist. Jetzt können Sie erst über das Menü „Optionen“ -> „Richtlinenvorlage..“ eine eigene ADM-Datei laden (hier können Sie auch mehr als eine ADM-Datei hinzufügen).

Danach können Sie über „Datei“ entweder eine bestehende Richtlinie laden (.POL) oder eine neue Richtlinie erstellen.

Wenn Sie diese Datei nach Ihren wünschen erstellt und konfiguriert haben, speichern Sie die Datei unter den Namen „NTCONFIG.POL“ ab und legen Sie diese Datei einfach im NETLOGON-Verzeichnis ihres Rechner ab. Der Rechner lädt diese Datei bei der Anmeldung automatisch und wertet die Einstellungen aus.

Achtung: Passen Sie auf, dass Sie sich mit den Einstellungen nicht selber aussperren. Da die Einstellungen bei der Anmeldung in der Registry abgelegt werden, reicht es nicht, diese Datei wieder zu löschen, die Einstellungen bleiben dann trotzdem erhalten.

Windows 2000/XP/2003

  • Starten Sie MMC.EXE

  • Fügen Sie über „Datei“ -> „Snap-In hinzufügen/entfernen“ Button -> „Hinzufügen“ das Snap-In „Gruppenrichtlinienobjekt-Editor“ hinzu bzw. Starten Sie das SNAP-IN „gpedit.msc“ über „Start“ -> „Ausführen“.

  • Öffnen Sie den Baum „Richtlinen für Lokaler Computer“ -> „Coputerkonfiguration“ und klicken Sie mit der rechten Maustaste z.B. auf „Administrative Vorlagen“. Hier erscheint jetzt ein Kontextmenü wo Sie den Eintrag „Vorlagen hinzufügen/entfernen…“ auswählen

  • Es öffnet sich ein neues Fenster in dem alle geladenen ADM-Vorlagen angezeigt werden. Über den Button „Hinzufügen“ können Sie eine ADM-Datei einfügen bzw. über den Button „Entfernen“ wieder entladen.

  • Drücken Sie jetzt auf den „Button“ hinzufügen (es wird ein Auswahlfenster in Verzeichnis „%systemroot%\inf“ angezeigt) gehen Sie zum gewünschten Verzeichnis und wählen Sie Ihre erstellte (oder eine andere) ADM-Datei aus.

  • Klicken Sie anschließend auf „Schließen“, Windows fügt nun die ADM-Datei hinzu, was ja nach Dateigröße eine gewisse Zeit dauern kann, da Windows den Aufbau der Datei überprüft.

  • Die Datei wird von Windows im Verzeichnis „%SystemRoot%\System32\GroupPolicy\Adm“ abgelegt


Warum werden einige ADM-Vorlagen nach dem Import nicht angezeigt?

Ab Windows 2000 kann es im Gruppenrichtlinieneditor, durch die von MS standardmäßig voreingestellte Ansicht, dazu kommen das einige Einträge aus den ADM-Dateien nicht angezeigt werden. Dafür stehet da dann „In dieser Ansicht werden keine Elemente angezeigt“.

Damit wirklich alle Einträge angezeigt werden und MS keine Einstellung ausblendet müssen Sie folgendes machen.

Bei Windows 2000:

Klicken Sie mit der rechten Maustaste in linken Fenster auf den Tipptext und wählen Sie aus dem Kontextmenü den Eintrag „Ansicht“ aus, entfernen Sie bei „Nur Richtlinen anzeigen“ den Hacken.

Ab XP/2003:

Klicken Sie mit der rechten Maustaste in linken Fenster auf den Tipptext und wählen Sie aus dem Kontextmenü den Eintrag „Ansicht“ -> „Filterung..“ aus und entfernen Sie hier den Hacken bei „Nur vollständig verwaltbare Richtlinieneinstellungen anzeigen“.

Warum werden diese ADM-Einträge nicht angezeigt?

Ab Windows 2000 hat MS die Gruppenrichtlinien so aufgebaut, dass die Einträge in extra Bereichen der Registry gespeichert werden. Wird ein Gruppenrichtlinienobjekt gelöscht, werden diese Einträge automatisch auch aus der Registry entfernt und sind dadurch nicht mehr gültig.

Diese Einträge werden in der Registry unter:

\Software\ Policies

\Software\ Microsoft\ Windows\ CurrentVersion\ Policies

abgelegt. Alle anderen Einträge ändern die entsprechenden Einstellungen in der Registry direkt. Wird hier die entsprechende Vorlage gelöscht, werden die alten Einstellungen nicht wieder hergestellt.

Ist die Anzeige aktiv können diese Einstellungen im Gruppenrichtlineneditor anhand der Farbe erkannt werden. Alle BLAUEN Einträge sind echte Policy-Werte und werden nach löschen des Gruppenrichtlinienobjektes wieder aus der Registry entfernt. Die ROTEN Einträge verändern den entsprechenden Eintrag in der Registry direkt. Da hier die alte Einstellung nicht erhalten bleibt, können die Veränderungen durch löschen des Gruppenrichtlinienobjektes nicht zurückgenommen werden.


Allgemeine Hinweise

Allgemeine Hinweise zur Handhabung von auftretenden Problemen

Tritt ein Fehler bei der Installation auf, dann sollten Sie als allererstes sicherstellen, dass Sie genügend Rechte auf Ihrem PC haben. Sie benötigen zur Installation mindestens Administrator-Rechte.

Deaktivieren Sie ggf. während der Installation installierte Virenscanner und Firewall.

Schauen Sie in der Fehlerliste nach, ob das aufgetretene Problem dort schon aufgeführt wird.

Falls nicht, dann schauen Sie im RSW-Forum nach, ob der Fehler evtl. schon bei jemand anders aufgetreten ist und Sie so zur Lösung des Problems kommen.

Wenn Sie nicht fündig werden, dann posten Sie im Forum einfach den Fehler. Sie müsen aber unbedingt die folgenden Punkte mit angeben:

RSW-Version z.B: 1.5.7 - hier erfahren Sie die RSW-Version

DB-Version z.B: 1.3.0 - hier erfahren Sie die DB-Version

Ihr Betriebssystem - hier erfahren Sie das Betriebsystem

Ein Debuglog - hier erfahren Sie, wie man ein solches erstellt

Diese Informationen stellen Sie im RSW-Forum bereit, damit Frank Ullrich anhand Ihrer Informationen den Fehler aufspüren kann.


Fehlerliste

Hier finden Sie jetzt die neue Fehlerliste der Produktiv-Version des RSW. Jeder Fehler wird hier jetzt mit einer entsprechenden Nummer aufgeführt und der Status (FIX) wird angezeigt.

Meldungs NR. | Datum | RSW Version | Meldung | Anmerkung | FIX | Versionsnr. behoben
0021 | 23.01.2005 | 1.5.9 | urden Tipps zur eigenen Tippdatenbank hinzugefügt, konnte es beim beenden vom RSW zu einen Absturz kommen. | - | ja | 1.6.0
0020 | 22.01.2005 | 1.5.9 | Die Registrierung wurde nicht in allen Fällen fehlerfrei erkannt | - | ja | 1.6.0
0019 | 18.12.2004 | 1.5.8 | Unter WIN98SE (nicht unter WinXP) erfolgt reproduzierbar kein regulaeres Programmende, sondern ein Programmabsturz mit einer Fehlermeldung auf einen ungueltigen Vorgang: "RSW verursachte einen Ausnahmefehler 10H in Modul MSVBVM60.DLL bei 0167:660d0956", sofern man bei der RSW-Passwortabfrage auf Abbruch klickt. | Fehler gefunden und behoben | ja | 1.5.9
0018 | 20.12.2004 | 1.5.8 | Beim Starten vom RSW kommt es auf einigen Rechner zum Fehlernummer 75 und 35600. | Die Bilder können nicht aus der Ressource geladen werden, die Funktion wurde umgebaut. | ja | 1.5.9
0017 | 19.09.2004 | 1.5.7 | Unter Tabreiter „alle“ werden nicht mehr alle Tipps angezeigt, wenn mehr als ein Betriebsystem unter den Einstellungen angekreuzt wurde. | Anstatt die einzelnen Betriebssysteme mit or zu verknüpfen wurden sie über and in der Select-Abfrage verbunden. Somit wurden nur die Tipps gefunden die für beide Betriebssysteme gedacht sind, alle anderen nicht. | ja | 1.5.8
0016 | 19.09.2004 | 1.5.7 | Alle INI-Tips werden nicht mehr im Tree angezeigt und können nur über die Suche gefunden werden | In der DB waren diese Tipps keiner Gruppe zugeordnet | ja | 1.5.8
0015 | 30.07.2004 | 1.5.5 | Wird eine ADS-Datei mit dem RSW-Programm erstellt kann folgendes passieren: Bei einigen Tipps kann man den Eintrag nur aktivieren oder auf "Moire" (Wert nicht verändern) setzen, nicht aber auf löschen. Somit können EInstellungen nicht wieder zurückgenommen werden. | In der ADM-Datei wurde der Eintrag: "ValueON NUMERIC 1" erstellt. Wird dieser Eintrag gemacht, muss auch der Eintrag "ValueOFF DELETE" erstellt werden. Es werden jetzt immer beide Einträge erzeugt, damit ist der Fehler behoben | ja | 1.5.6
0014 | 11.07.2004 | 1.5.4 | Wird über das Netzwerk auf einen Rechner zugegriffen, können nur bestehende Einträge geändert werden. Es können keine neuen Einträge angelegt werden. | Beim überprüfen der Rechte über das Netzwerk, gab es einen Fehler bei Keys die nicht vorhanden waren. So wurden hier nur lesende Rechte festgestellt. | ja | 1.5.5
0013 | 13.06.2004 | 1.5.2 | Beim ändern der Einstellung: "e-Mail Vorschau bei Outlook Express" für den aktuellen User bekomme ich beim übernehmen der Einstellungen eine Fehlermeldung. Die Meldung kommt unabhängig von Adminrechten und ob der Schlüssel bereits besteht oder nicht, da in der Meldung auch HKLM steht. Manuell kann ich den entsprechenden Schlüssel anlegen und bearbeiten. | Wird in einen Tipp auf dem gleichen Tabreiter auf zwei unterschiedliche Rootkeys zugegriffen, wird der zweite Rootkey nicht mehr ausgewertet. Beim nächsten Eintrag wird immer noch der erste Rootkey benutzt. | ja | 1.5.4
0012 | 10.06.2004 | 1.5.2 | Die History und Favoriten-Liste wird nicht mehr geladen und kann auch nicht erstellt werden. | Fehler im Aufruf | ja | 1.5.3
0011 | 04.06.2004 | 1.5.1 | Beim erstellen von ADM-Datein (Liste) kommt es zu Fehlern. Weiterhin werden einige ADM-Datei nicht richtig erzeugt und können mit POLEDIT.EXE nicht gelesen werden. | Das schreiben der ADM-Dateien vollständig überarbeitet und getestet. Weiterhin die Funktion für Listen noch erweitert. | ja | 1.5.2
0010 | 31.05.2004 | 1.5.1 | Tipp "Registrierte Programmeinträge unter Uninstall entfernen". Hier kommt die Fehlermeldung, dass man keinen Rechte hat, diesen Key zu ändern. Aber ich habe ja Lesezugriff auf den Registry-Zweig. Ebenso bei: Windows Software Update Konfigurieren. Da habe ich ja als Normal-User auch keine Rechte. | Meldet sich ein User mit geringen Rechten an, muss das ändern von entsprechenden Tipps unterbunden werden, damit solche Meldungen nicht kommen. Muss dafür das Programm anpassen. | nein |
0009 | 31.05.2004 | 1.5.1 | Eigene Tipps erstellen: leer.mdb kopieren nach test.mdb Meinen eigenen Tipp eintragen und DB speichern RSW starten und test.mdb laden, dann kommt die Fehlermeldung, dass die test.mdb zu alt ist. | Anpassungen auch in der leer.mdb vorgenommen. | ja | 1.5.2
0008 | 31.05.2004 | DB:1.3.32 | Tipp: Icon-Cache erhöhen. Hier unterschiedet sich die maximale Größe in der WinFAQ zu der im RSW. | Die maximale Größe in der WinFAQ ist richtig, die im RSW ist zu klein… | ja | DB: 1.3.33
0007 | 31.05.2004 | DB:1.3.32 | Wenn man beim Tipp: Desktop nicht speichern Ein-/Ausschalten das Häkchen setzt, wird der Desktop beim Beenden nicht gespeichert. Verändert man nun per RSW (oder auch anders) etwas an meinem Desktop (z. B. die Fensteranimation: Animation der Fenster beim Minimieren/Maximieren ausstellen), dann wird das zwar für die aktuelle Session geändert, aber beim Neustart ist alles wieder beim Alten (logischerweise!). | Der Text wird bei diesen Tipp mit den entsprechenden Hinweis angepasst. | ja | DB: 1.3.33
0006 | 31.05.2004 | DB:1.3.32 | Tipp: kein "Klicken Sie hier…." mehr. Dieser Tipp zeigt keine Wirkung | Das bezieht sich nicht auf die PopUp Menüs sondern auf das Anzeigen einer Textmeldung von MS, die sonst ab und zu dort eingeblendet wird. Fix: Beschreibung etwas geändert | ja | DB: 1.3.33
0005 | 31.05.2004 | DB:1.3.32 | Tipp: Startmenü ausschalten, dieser Tipp funktioniert nicht. | Der Text ist falsch. Damit wird nur die Drag und Drop Funktion des Startmenüs ausgeschaltet. Das Startmenü bleibt aber sichtbar. Weiterhin geht das nur, wenn Active Desktop nicht aktiv ist. Neuer Name: Kontextmenü des Startmenüs deaktivieren | ja | DB: 1.3.33
0004 | 31.05.2004 | 1.5.1 | Beim erstellen eines Registry-Backup kommt die Meldung: "zu viele Daten". | Fehler kann nicht nachgestellt werden, warte auf Log-Datei des Anwenders. | nein |
0003 | 31.05.2004 | 1.5.1 | Fehler bei der Installation des RSW. Ist noch keine JET-Engine installiert, und wird die Installation vom RSW-Setup durchgeführt, friert die Installation nach dem Download ein und es geht nicht mehr weiter. | Wird noch mal überprüft. Als Workaround: Jet-Engine von Hand installieren. Selber konnte ich diesen Fehler noch nicht nachstellen. | nein |
0002 | 31.05.2004 | DB:1.3.32 | Tipp: Willkommensseite mit der Anzahl der neuen E-Mails. Auch Mails von "Mozilla Thunderbird" werden hier angezeigt, der Beschreibungstext muss erweitert werden. |  | ja | DB: 1.3.33
0001 | 31.05.2004 | DB:1.3.32 | Hilfe und Support ausblenden. Dieser Tipp ist zwar in der WinFAQ vorhanden, wurde aber noch nicht in den RSW übertragen (NoSMHelp). |  | ja | DB: 1.3.33


Fehlermeldung: Datentypen unterschiedlich

Dieser Fehler hat folgende Bedeutung:

In der Tippdatenbank des WinFAQ Registry System Wizard wird zu jedem Registryeintrag angegeben, mit welchem Datentyp dieser Wert in der Registry angelegt werden muß.

Wenn Sie einen Tipp im Programm auswählen, wird geschaut, ob es diesen Eintrag in der Registry schon gibt. Wenn ja, wird er ausgelesen und angezeigt.

Wird dabei festgestellt, dass dieser Eintrag bei Ihnen als ein anderer Datentyp als in der Datenbank angegeben angelegt wurde, wird aus Sicherheitsgründen diese Fehlermeldung ausgegeben.

Warum können sich die Datentypen unterscheiden ?

1. Es liegt ein Fehler in der Tippdatenbank vor, und darum unterscheiden sich die Datentypen

2. Der Wert wurde bei Ihnen in der Registry mit einem falschen Datentypen eingetragen

3. Dieser Wert kann mit verschiedenen Datentypen angelegt werden

4. Der Tipp wurde nur für ein bestimmtes Betriebssystem und nicht unter Ihrem Betriebsystem getestet.

Wenn dieser Fehler bei Ihnen auftritt, haben Sie folgende Möglichkeiten:

1. Sie drücken auf "Abbrechen", dann wird dieser Tipp verlassen und nichts in Ihrer Registry verändert.

2. Sie drücken auf "Weiter", dann wird dieser Eintrag in Ihrer Registry nicht weiter berücksichtigt und der Tipp wird mit den Windows Standardwerten angezeigt. Wenn Sie dann auf "Speichern" klicken, wird dieser Wert mit dem in der Tippdatenbank angegebenen Datentyp in der Registry gespeichert und der alte Eintrag damit überschrieben.

3. Sie drücken auf "eMail", dann wird eine eMail mit den nötigen Informationen an den Autor des Programmes geschickt, damit er feststellen kann, ob es ein Programmfehler ist.

Was soll ich machen?

Leute, die sich nicht mit der Registry auskennen, sollten auf jeden Fall lieber auf "Abbrechen" bzw. "eMail" drücken und an den aktuellen Einstellungen nichts verändern. Ein fehlerhafter Datentyp kann dazu führen, dass Windows diesen Wert nicht mehr oder falsch auswertet, was im schlimmsten Fall dazu führen kann, dass Ihr System nicht mehr funktioniert.

Wollen Sie trotzdem weitermachen, sollten Sie sich den alten Datentyp notieren und Ihre Registry sichern. So können Sie im Notfall die Veränderung wieder rückgängig machen.


Registry Backup bringt eine Fehlermeldung

Erscheint die Fehlermeldung:

„Nicht genügend Systemressourcen, um den angeforderten Dienst auszuführen“ ist die Ursache meist die Folgende:

Es gibt in der Registry einen Eintrag, in dem Windows die Icons für den Infobereich ablegt.

Es kann vorkommen, dass bei der Deinstallation von Programmen dieser Eintrag nicht richtig neu erstellt wird und dann fehlerhaft ist. Das hat unteren anderen dann auch zur Folge, dass kein Registry-Backup mehr durchgeführt werden kann.

Folgendes muß gemacht werden, um den Fehler zu beheben:

Mit einem Editor erstellen Sie eine Datei mit folgendem Inhalt:

Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Explorer\ TrayNotify]

"PastIconsStream"=-

"IconStreams"=-

Diese Datei speichern sie unter einen beliebigen Namen ab, aber mit der Endung .reg (z.B.: Clean.reg)

Führen Sie diese Datei durch einen Doppelklick aus und bestätigen Sie die folgende Sicherheitsabfrage:

Dabei werden die fehlerhaften Einträge aus der Registry gelöscht.

Da der Explorer diese Informationen aber noch im Speicher hält und beim normalen Beenden von Windows diese wieder in die Registry zurückschreiben würde, müssen wir den Explorer noch hart beenden!

Sie öffnen dafür den Taskmanager, klickt auf die Registerkarte Prozesse, markieren die "Explorer.exe" und klicken auf den Button Prozess beenden.

(Wenn es mehr als eine "Explorer.exe" gibt, müssen Sie das so oft wiederholen, bis alle weg sind).

Jetzt noch in der Menüleiste auf "Datei" und "Neuer Task (Ausführen...)" klicken,

"explorer.exe" eingeben und mit "OK" bestätigen.

Jetzt wird der Eintrag in der Registry neu erzeugt und hat wieder gültige Einträge.


RSW Debug-Modus

Wenn das Programm mit einem Fehler abstürzt, können Sie ein Fehlerprotokoll erstellen, welches Sie mir dann zur Fehleranalyse zusenden können. Dafür gehen Sie folgendermaßen vor:

Starten der Verknüpfung im Startmenü: "RSW im Debugmodus starten!"

Dann erscheint der RSW-Debugger in welchem Sie per Datei | Aufzeichnung starten die Aufzeichnung starten!

Dann wählen Sie einen Speicherort für das DEBUG-LOG aus!

Im folgenden Dialogfenster bekommen Sie das Angebot, den RSW zu starten, welches Sie dankend annehmen.

Es dauert etwas länger bis der RSW gestartet ist, da alles aufgezeichnet wird.

Führen Sie nun die Funktion aus, wo der Fehler vorkommt.

Dann schliessen Sie den RSW und beenden die Aufzeichnung indem Sie im RSW-Debugger über Datei | Aufzeichnung beenden.

Als Ergebnis sollten Sie eine schöne LOG-Datei haben, die etliche Einträge enthält.

Diese LOG-Datei senden Sie an Frank Ullrich oder stellen Sie im RSW-Forum zur Verfügung.


RSW startet nicht

Wenn Sie den Registry System Wizard starten und es kommt bei Ihnen folgende Fehlermeldung:

Registry System Wizard:

rswADO.ConnectAccess

Err : 3706 [&hE7A]

Der Provider kann nicht gefunden werden. Möglicherweise ist er nicht richtig installiert worden.

Source: ADODB.Properties

C:\Programme\Registry System Wizard\RSWDaten.mdb

oder

FehlerLoadDB91

bzw. so ähnlich, dann liegt es meist daran, dass entweder kein MDAC und JET-Provider installiert ist oder aber ein Fehler in der ODBC-Anbindung vorliegt.

Die aktuelle Versionen von MDAC und dem JET-Treiber finden Sie bei Microsoft unter den folgenden Adressen:

Übersicht der Versionen:

http://msdn.microsoft.com/data/downloads/updates/default.aspx

Aktuelle MDAC-Version 2.8 unter:

http://www.microsoft.com/downloads/details.aspx?FamilyID=6c050fe3-c795-4b7d-b037-185d0506396c&DisplayLang=en

Aktuelle JET-Treiber Version 4.0 Service Pack 8 unter:

Jet 4.0 SP8 for Windows 2003

Jet 4.0 SP8 for Windows XP

Jet 4.0 SP8 for Windows 2000

Jet 4.0 SP8 for Windows 95/98/NT 4.0

Jet 4.0 Service Pack 7 for Windows Millennium Edition

Wenn es dann immer noch nicht geht, sollten Sie die Installation mit den MDAC-Checker überprüfen:

Sie finden das Tool unter:http://www.microsoft.com/downloads/details.aspx?FamilyId=8F0A8DF6-4A21-4B43-BF53-14332EF092C9&displaylang=en


RSW-Start-Parameter

Die RSW.EXE kann auch mit einigen Parametern aufgerufen werden:

RSW /?

Übersicht über die Parameter

RSW /DEBUG

Startet den Registry System Wizard im Debug-Modus.

RSW /nodb

Startet den RSW ohne Datenbank. Es wird also kein MDAC benötigt. Sie können damit ein Backup der Registry wieder zurückspielen bzw. erstellen, auch wenn MDAC auf den Rechner gerade nicht läuft.

Nur für Windows NT, 2000, XP, 2003:

RSW /PC:<Rechnername>

Verbindet sich beim Start mit der Registry des angegebenen Rechners, hierbei können noch optional folgende Parameter übergeben werden:

RSW /PC:<Rechnername> /U:<Account> /PW:<Password>

Beispiel:

RSW.EXE /PC:MeinZweitrechner /U:administrator /PW:Passort

U: Der Accountname, mit dem die Verbindung zum Rechner aufgebaut wird

PW: Das Passwort

Wird kein Accountname und Passwort angegeben, wird versucht die Verbindung mit dem aktuellen Account aufzubauen.


Silent Installation

Silent Instalation

Sie können den Registry System Wizard auch unbeaufsichtigt installieren, d. h. es sind keine Benutzeringaben notwendig.

Dazu benutzen Sie die Parameter /silent oder /verysilent

Der Aufruf erfolgt folgendermaßen:

Pfad_zur_Installationsdatei\rswsetup.exe /silent bzw. Pfad_zur_Installationsdatei\rswsetup.exe /verysilent

Weitere Parameter sind:

/SP-

Deaktiviert die Start-Abfrage, ob man das Programm installieren möchte.

Natürlich hat dieser Parameter nur eine Wirkung, wenn diese Start-Abfrage im SETUP auch aktiviert ist...

/SILENT

Es werden keinerlei Benutzerabfragen durchgeführt, jedoch wird der Installationsprozess angezeigt...

Ist ein Reboot notwendig, so kommt am Schluss der Installation die Nachfrage, ob man rebooten möchte...

/VERYSILENT

Es werden keinerlei Benutzerabfragen durchgeführt und es wird auch kein Installationsprozess angezeigt...

Ist ein Reboot notwendig, so kommt am Schluss der Installation keine Nachfrage, ob man rebooten möchte...

Wil man den Reboot unterdrücken kann man den Parameter /NORESTART mitgeben...

/LOG

Dieser Parameter erstellt im Benutzer-Temp-Verzeichnis eine LOG-Datei über den installations-Prozess.

Dieser Parameter ist bei /SILENT und /VERYSILENT sehr hilfreich, um Fehler aufzuspüren...

/NOCANCEL

Dieser Parameter unterbindet das Abbrechen des Installationsprozesses.

Dieser Parameter ist bei /SILENT und /VERYSILENT sehr hilfreich...

/NORESTART

Führt nach der Installation keinen Reboot aus, auch wenn es eigentlich vorgegeben war.

/DIR="x:\dirname"

Gibt ein anderes Standard-Installations-Verzeichnis an

/GROUP="folder name"

Gibt ein anderes Standard-Startmenü-Verzeichnis an

Wenn im Setup das Ändern des Startmenü-Verzeichnisses nicht gestattet ist, so wird dieser Parameter ignoriert...

/NOICONS

Aktiviert die Checkbox, keine Startmenü-Einträge zu erzeugen...


Glossar

Wichtige Begiffserklärungen

HKEY_CLASSES_ROOT

HKEY_CURRENT_CONFIG

HKEY_CURRENT_USER

HKEY_LOCAL_MACHINE

HKEY_USERS

REG_BINARY

REG_DWORD

REG_EXPAND

REG_MULTI_SZ

REG_SZ

Unicode

HKEY_CLASSES_ROOT

Teilschlüssel von HKEY_LOCAL_MACHINE\Software. Die hier gespeicherten Informationen gewährleisten, dass das richtige Programm gestartet wird, wenn Sie eine Datei im Windows-Explorer öffnen.

HKEY_CURRENT_CONFIG

Enthält Informationen über das Hardwareprofil, das vom lokalen Computersystem beim Start verwendet wird.

HKEY_CURRENT_USER

Enthält Konfigurationsinformationen für den aktuell angemeldeten Benutzer. Hier werden die Ordner des Benutzers, die Bildschirmfarben und die Einstellungen der Systemsteuerung, kurz genannt das „Profil“ des Benutzers, gespeichert

HKEY_LOCAL_MACHINE

Enthält für den Computer spezifische Konfigurationsinformationen (für alle Benutzer).

HKEY_USERS

Enthält alle auf dem Computer vorhandene Benutzerprofile. HKEY_CURRENT_USER ist ein Teilschlüssel von HKEY_USERS.

Binär-Wert (Binary) = REG_BINARY, binär, dezimal und hexadezimal. Hexadezimale Zahlen zwischen 00 und FF, sie entsprechen den Dezimalzahlen 0 bis 255. Ein definierter Wert muss mindestens 4 Byte (32 Bit) umfassen.

DWORD-Wert (DWORD) = REG_DWORD, Werte von 4 Byte (Doppelwort = Double-Word), Zahlenwert zwischen 0 und 255 (Dezimal) oder 00 und FF (Hexadezimal). Der Wert wird im Format 0x00000000 (0) dargestellt. Die erste Zahl ist die hexadezimale Darstellung des Wertes 0x00000000, während der Dezimalwert in Klammern steht (0).

Wert der erweiterbaren Zeichenfolge = REG_EXPAND_SZ (expandierbarer Text), eine erweiterbare Zeichenkette mit Variablen wie %SYSTEMROOT%, die durch die jeweils aktuellen Werte ersetzt werden, wenn ein Programm oder ein Dienst darauf zugreift (nur Windows XP).

Wert der mehrteiligen Zeichenfolge = REG_MULTI_SZ, eine mehrzeilige Zeichenkette (Mehrfachzeichenkette), zum Beispiel eine Liste, in der die Einträge durch Leerzeichen, Kommas oder andere Trennzeichen voneinander getrennt werden (nur Windows XP).

Zeichenfolge (String) = REG_SZ, reiner, beliebiger Klartext (Zeichenkette)

Unicode

Unicode ist eine Zeichencodierungsnorm, die im Gegensatz zu ASCII nicht 8 sondern 16 Bit zur Zeichencodierung verwendet, wodurch praktisch alle bekannten Schriftzeichen darstellbar sind (z.B. lateinische, kyrillische, japanische und chinesische). Das A wird dadurch in der Registry als 0041 abgelegt. Damit hier auch entsprechende Einträge gefunden werden, müssen diese Einträge umgewandelt werden.


Registry Defrag

Die Registry wird ähnlich wie ein Dateisystem mit der Zeit fragmentiert. Diese fragmentierung wird durch die Installation und Deinstallation von Programmen hervorgerufen.

Dadurch belegt die Registry mit der Zeit immer mehr Platz auf der Festplatte als sie eigentlich benötigt und das System wird auch verlangsamt.

Wenn Sie mit den Registry Cleaner Ihre Registry aufgeräumt haben, sollten Sie anschließend durch einen Defragmentierungslauf die Größe der Registry anpassen.

Durch den Start dieser Funktion, wird die Registry weggesichert und anschließend neu eingespielt. Dadurch werden freie Speicherbereiche in der Registry wieder freigegeben.

Der Defragmenierungslauf wird einige Minuten dauern, Sie sollten vorher alle laufenden Programme beenden und anschließend den Rechner neu starten. Starten Sie nach dem Neustart des Rechners den „Registry System Wizard“ noch mal, da beim Start automatisch die Temporären „Defragmentierten“ Registrydateien gelöscht werden.


Fehlerliste - Beta-Version

Hier finden Sie die Fehlerliste der extra BETA-Versionen des RSW. Diese Version ist für aktive Betatester freigeschaltet.

Jeder Fehler wird hier jetzt mit einer entsprechenden Nummer aufgeführt und der Status (FIX) wird angezeigt.

Meldungs NR. | Datum | RSW Version | Meldung | Anmerkung | FIX | Versionsnr. behoben
B-0012 | 01.06.2004 | 1.5.2 - 0.1.2 | Beim export von Registryeinträgen unter "Extras" -> "Registry durchsuchen..." werden für den Rootkey die kurzen Bezeichnungen benutzt (HKCU), deshalb kann die REG-Datei unter Windows nicht importiert werden. | Eine konvertierung der Keys auf den landen Namen eingebaut (HKEY_CURRENT_USER) | ja | 1.5.2 - 0.1.3
B-0011 | 31.05.2004 | 1.5.2 | Läuft der RSW in einen Fehler, kann er nicht mehr richtig beendet werden | Muss ich mir mal die Fehlerbehandlung ansehen. Beim auftreten eines Fehler, scheint er sich nicht mehr richtig zu beenden. | nein |
B-0010 | 31.05.2004 | 1.5.2 | Es kommt ein Fehler beim löschen von Fehlerhaften AX und COM Objekten im Cleaner: FehlerSettvwReg92 |  | nein |
B-0009 | 31.05.2004 | 1.5.2 | Es wird eine MSGBOX beim Cleaner Lauf angezeigt | Habe ich vergessen zu entfernen, da wollte ich an einer bestimmten Stelle anhalten | nein |
B-0008 | 30.05.2004 | 1.5.1 | Die erstelle Registry-Datei mit den Fehlerhaften Einträgen wird nicht richtig erstellt. | Diese Funktion wurde vollständig überarbeitet | ja | 1.5.2 - 0.1.2
B-0007 | 30.05.2004 | 1.5.1 | Als normaler User gibt es beim Cleaner viele Fehlermeldungen. | Der Cleaner macht als normaler User keinen sind, dass starten wird dann unterbunden, wenn keine Administrativen Rechte vorliegen. | ja | 1.5.2 - 0.1.2
B-0006 | 30.05.2004 | 1.5.1 | Viele Hilfe-Button sind noch ohne Funktion |  | nein |
B-0005 | 30.05.2004 | 1.5.1 | Wenn ich darauf wieder alles auswähle und dann noch mal auf löschen gehe, kommt wieder die Meldung ob ich wirklich löschen möchte. Wenn ich dann "Ja" klicke, erscheint eine neue Fehlermeldung: "FehlerRegDelete 52" | Folgefehler zu der Meldung B-4 | ja | 1.5.2 - 0.1.2
B-0004 | 30.05.2004 | 1.5.1 | Wenn ich im Cleaner fehlerhafte Einträge markiere und dann auf löschen klicke, erscheint ein Abfrage "Sollen die markierten Einträge gelöscht werden?". Wenn man bei dieser Meldung auf "Nein" klickt, erscheint darauf eine Meldung: "Fehlerhafte Einträge wurden gelöscht". Danach sind alle ausgewählten Einträge zurückgesetzt, wirklich gelöscht ist aber nichts. | Wird jetzt auf nein geklickt, wird nichts zurückgesetzt und es wird nur zur Anzeige zurückgesprungen. | ja | 1.5.2 - 0.1.2
B-0003 | 30.05.2004 | 1.5.1 | Registry Defrag wird auch nicht richtig durchgeführt | Wird noch mal richtig überarbeitet. Hier wird der Anwender dann auch gleich zu Anfang drauf hingewiesen, dass ein (Keine Vorschläge) unbedingt nötig ist und auch automatisch nach Abschluss durchgeführt wird. Auch das Löschen der Dateien schaue ich mir noch mal an. | nein |
B-0002 | 30.05.2004 | 1.5.1 | RSW läst sich nach einem Fehler nicht mehr richtig beenden und bleibt als Task im System. | Folgefehler der Meldung B-1 | ja | 1.5.2 - 0.1.2
B-0001 | 30.05.2004 | 1.5.1 | Wird während des Cleaner Laufs auf Abbruch gedrückt, erschient eine Fehlermeldung |  | ja | 1.5.2 - 0.1.2


Updateübersicht

Hier finden Sie jetzt die neue Updateübersicht vom RSW, die Informationen wurden jetzt in unterschiedliche Bereiche aufgeteilt:

  • BUG-Liste, hier finden Sie die gemeldetet Fehler und den aktuellen Status. Dadurch können jetzt auch bekannte Fehler aufgeführt werden, auch wenn sie noch nicht beseitigt wurdem

  • Die Liste mit neuen Funktionen usw.

Version | Datum | Beschreibung
1.5.6 | 08.08.2004 | Datenbank wurde Überarbeitet
1.5.6 | 08.08.2004 | Tipp No. 434 Hand unter Freigaben entfernen Änderungen wurden nicht in die Datenbank geschrieben
1.5.2 | 30.05.2004 | Die Funktion "Registry durchsuchen…" wurde weiter überarbeitet
1.5.2 | 30.05.2004 | Erstellen von Registrydateien (.REG) wurde vollständig überarbeitet.
1.5.2 | 30.05.2004 | In der Funktion "Registry durchsuchen…" können die gefunden Einträge jetzt auch in eine REG-Datei exportiert werden.
1.5.2 | 30.05.2004 | Löschen von Keys ist in der Funktion "Registry durchsuchen..." möglich, diese Funktion befindet sich aber noch im TEST und ist deshlab noch mit Vorsicht zu benutzen.
1.5.2 | 30.05.2004 | Ist MDAC oder der JET-Provider nicht richtig installiert und kann deshalb die Datenbank nicht geladen werden, wurde das Programm beendet. Leider kann man dann auch kein Backup der Registry mehr mit dem RSW zurückspielen. Für diese Funktion wird aber die Datenbank nicht benötigt. Wollen Sie also nur ein Backup der Registry zurückspielen, rufen Sie den RSW mit dem Parameter /nodb auf. Es wird dann keine Datenbank geladen und Sie haben die Möglichlkeit ein Backup/Restore der Registry durchzuführen.